В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Nnas22
Nnas22
12.12.2021 01:07 •  Информатика

Надо к завтрашнему : составьте программу в паскале вычислите площадь треугольника , две стороны которого равны а и b , а угол между ними равен d (в градусах)

Показать ответ
Ответ:
Мышка007
Мышка007
02.10.2020 01:24
Program zd;
const
t=0,5;
var
a,b,c:byte;
r,s:real;
begin
writeln('Введите сторону А');
readln(a);
writeln('Введите сторону В');
readln(b);
writeln('Введите угол С (в градусах)');
readln(c);
r:=c*pi/180; {Перевод из градусов в радианы}
s:=t*a*b*sin(r); {Формула для вычисления}
writeln('Результат = ',s);
readln; {Сразу выводит результат на монитор без нажатия Ctrl+F9 (вроде бы)}
end.
Вроде бы так, попробуй запустить проверить
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота