Начертить блок схемы к задачам из питона «Минимум из двух чисел» Даны два целых числа. Выведите значение наименьшего из них; «Шахматная доска» Заданы две клетки шахматной доски. Если они покрашены в один цвет, то выведите слово YES, а если в разные цвета — то NO. Программа получает на вход четыре числа от 1 до 8 каждое, задающие номер столбца и номер строки сначала для первой клетки, потом для второй клетки; «Високосный год Дано натуральное число. Требуется определить, является ли год с данным номером високосным. Если год является високосным, то выведите YES, иначе выведите NO. Напомним, что в соответствии с григорианским календарем, год является високосным, если его номер кратен 4, но не кратен 100, а также если он кратен 400. Шоколадка Шоколадка имеет вид прямоугольника, разделенного на n×m долек. Шоколадку можно один раз разломить по прямой на две части. Определите, можно ли таким образом отломить от шоколадки часть, состоящую ровно из k долек. Программа получает на вход три числа: n, m, k и должна вывести YES или NO.» Сколько совпадает чисел Даны три целых числа. Определите, сколько среди них совпадающих. Программа должна вывести одно из чисел: 3 (если все совпадают), 2 (если два совпадает) или 0 (если все числа различны).
Я, в основном, программы на С++ пишу, но из школы про Паскаль кое-что помню (в смысле, попытаюсь написать на Паскале).
Program A1;
var a,b,c,i:integer;
begin
write('Enter the a: ');
read(a);
writeln('Enter the b: ');
read(b);
с:=0;
for i:=1 to a Do
c:=c+b;
writeln('a*b=',c:5:0);
end.
Объясняю (начинаю сразу с цикла for): что значит произведение двух натуральных чисел а и b - это означает, сложить b с самим собой по а раз (можно и наоборот). Например, a=5, b=3. Переменную с=0 будем складывать с b.
i=1 c=5+0;
i=2 c=5+5;
i=3 c=10+5; //c=15
Вот и есть ответ: 5*3=15.
Во-первых, электронная почта является очень удобной, учитывая скорость передачи сообщений. Отправляя письмо в любую точку планеты с любого места расположения, можно быть уверенным, что сообщение дойдет до своего адресата в течении нескольких секунд. Это есть очень большой плюс, учитывая современный ритм жизни.
Во-вторых, с электронной почты можно отправлять различного типа информацию в разных объемах и размерах. Можно пересылать любые файлы, например, фотографии, музыкальные произведения, текстовые файлы, презентации, видео и другие различные виды информационных сообщений. Главное, чтобы компьютер Ваш и Вашего собеседника поддерживал данные программы.
Третье преимущество заключается в том, что пользоваться электронной почтой невероятно легко и удобно. Это могут делать даже дети. Можно общаться с человеком по ту сторону экрана, не вставая с дивана или стула, не выходя из дома.