В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
DetaRUSION
DetaRUSION
24.01.2022 16:51 •  Информатика

Набор текста PYTHON 3 Алишер и Сержан соревнуются в быстром наборе текста. Им дается текст с S набором символов, скорость набора текста Алишера V1 символов в миллисекунду, а Сержан набирает V2 символов в миллисекунду. Также перед и после набора текста у них происходит ping(задержка обработки за на сервере), то есть, перед тем как получить текст и отправить его обратно на онлайн платформу . У Алишер T1 миллисекунд, а у Сержана T2 миллисекунд.
Последовательность выполнения действий является следующее:
Алишеру и Сержану в течении T1 и T2 времени приходит текст.
Затем как только текст пришел каждый начинает набор текста.
Затем как только они закончили набор текста они отправляют текст обратно за T1 и T2 времени.
Победителем является тот чей текст система обработала быстрее. Напишите программу, которая вычислит, кто является победителем.
Вводные данные:
На первой строке число S, количество символов в тексте.
На второй строке число V1 скорость набора текста Алишера.
На третьей строке число V2, скорость набора текста у Сержана.
На четвертой строке T1 ping в миллисекундах у Алишера.
На пятой строке T2, ping в миллисекундах у Сержана.
Выходные данные:
На одной строке если выиграл Алишер, имя "Alisher". Если выиграл Сержан, имя "Serzhan", а если текст обоих обработал в одно время слово "Friendship".
Пример 1
Ввод:
5
1
2
1
2
Вывод:
Alisher

Показать ответ
Ответ:
zac00
zac00
03.01.2023 00:09
 const     
        n = 3; //Кол-во фигур       
var   
   i : integer;   
   xk,yk : integer;   
   xl,yl : array [1..n] of integer;   
   r : boolean;  
begin   

 //Задание координат 
//   
xk := 2; yk := 2; // Координаты короля       
 //Координаты ладьи    
xl[1] := 1; yl[1] := 2;    
xl[2] := 4; yl[2] := 6;   
xl[3] := 5; yl[3] := 8;   
//   

r := false; 
i := 1;   
While (i <= n) and (not r) do   
begin   
if (xk = xl[i]) or (yk = yl[i]) then //Лежат на одной  прямой    
r := true;   
i:= i +1;   
end;   

if r then   
writeln ('Король под ударом') 
else   
writeln ('Король живет)'); 
end.
0,0(0 оценок)
Ответ:
Jullia123123
Jullia123123
06.11.2020 20:48
Var
 currentPos,wordsAmount:byte; groupWords:string;
 procedure isCorrect(startPos:byte);
  begin
   while currentPos+1<=length(groupWords) do
    if groupWords[currentPos+1]<>' ' then inc(currentPos) else break;
   if groupWords[startPos]=groupWords[currentPos] then
    inc(wordsAmount);
  end;
begin
 readln(groupWords); wordsAmount:=0; currentPos:=1;
 while currentPos<=length(groupWords) do
  begin
   if (groupWords[currentPos]<>' ') then isCorrect(currentPos);
   inc(currentPos);
  end;
 writeln(wordsAmount); readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота