В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

На языке си. напишите программу, которая получает два целых числа a и b (0 < a < b) и выводит квадраты всех натуральных чисел в интервале от a до b. пример: введите два целых числа: 10 12 10*10=100 11*11=121 12*12=144

Показать ответ
Ответ:
светульь
светульь
31.08.2020 06:57
#include <iostream>
#include <conio.h>
using namespace std;

int main()
{
    setlocale(LC_ALL,"Russian");
    unsigned long long A,B;
    cout << "Введите A(Начало) и B(Конец):\t";
    cin >> A >> B;
    if (A>0)
        for (unsigned long long i=A; i<=B; i++)
            cout << i << "\t - \t" << i*i << endl;
    else
    {
        cout << "Ошибка!";
        _getch();
        return -1;
    }
    _getch();
    return 0;
}

P.S. Это моя старая программа на C++, ПИСАЛ ЕЁ ДАВНО, использовал Microsoft Visual C++ 2010.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота