В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

На языке СИ написать программу В функцию передаются 4 числа. Определить наименьшее и наибольшее из этих чисел. Результат поместить в 2 глобальные переменные.

Показать ответ
Ответ:
tyzigfr
tyzigfr
07.03.2021 19:40

#include <stdio.h>

float gmax, gmin;

void privet(float a, float b, float c, float d) {

   float x[4], max, min;

   x[0] = a;

   x[1] = b;

   x[2] = c;

   x[3] = d;

   max = a;

   min = a;

   for (int i = 0; i < 4; i++) {

       if (max <= x[i])

           max = x[i];

       else if (min >= x[i])

           min = x[i];

   }

   gmax = max;

   gmin = min;

}

int main()

{

   float c1, c2, c3, c4;

   scanf("%f%f%f%f", &c1, &c2, &c3, &c4);

   privet(c1, c2, c3, c4);

   printf("Max:%f\nMin:%f", gmax, gmin);

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота