В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

На языке программирования паскаль составить программу суммы нахождения суммы вводимых с клавиатуры положительных чисел . печать результата по вводу 0 ( используя цикл while т.е. предусловие ).

Показать ответ
Ответ:
Qwer948
Qwer948
25.05.2020 17:16

var

 a, s: real; //a - вводимое с клавиатуры число, s - сумма чисел

 

begin

  a:= 1;  //Присваиваем начальное значение, чтобы цикл выполнился

  s:= 0;

  while a <> 0 do   

  begin

    writeln('Введите положительное число');

    readln(a);

    if a < 0 then

    begin

      writeln('Введено не положительное число. Повторите ввод заново');

      continue; {Если а - не положительное число, вводим число заново}

    end;

    s:= s + a;

  end;

  writeln('Сумма:  ', s);  //Выводим сумму

end.

  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота