На вход программы подаются 5 целых чисел. Составьте блок-схему и напишите программу, которая подсчитывает и выводит на экран сумму и произведение этих чисел. Если трудно выполнить оба расчета в одной программе, разрешаю дать мне две отдельные программы – одна с суммой, другая – с произведением.
#include <iostream>
void main()
{
int x;
std::cin>>x;
int sum = 0;
int prod = 1;
while(x>0)
{
int y = x%10;
sum = sum + y;
prod = prod * y;
x=x/10;
}
if(sum%10 == 0 && prod < 100)
std::cou<<"Yes"<<endl;
else:
std::cout<<"No"<<endl;
}
Pascal
var n,digit,sum,prod:integer;
begin
readln(n);
sum = 0;
prod = 1;
while (n>0) do
begin
digit:=n mod 10;
sum = sum+digit;
prod = prod * digit;
n:=n div 10;
end;
if(sum mod 10=0)and(prod<100)
begin
writeln("да");
end
else
begin
writeln("Нет"):
end;
Как то так
end.
дерево
наземная часть подземная часть
ветви ствол корни
листья , плоды кора корешки
учебника информатики 7 класс
глава I глава II глава III глава IV глава V
параграф1 параграф1 параграф1 параграф1 параграф1
параграф2 параграф2 параграф2 параграф2 параграф2
параграф3