В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
elkaE
elkaE
22.09.2021 01:18 •  Информатика

На вход программы подается количество вводимых чисел, а затем сами числа. Определить сколько вводимых чисел кратных 13. Вывести количество этих чисел.
2) На вход программы подается количество вводимых чисел, а затем сами числа. Числа положительные, не превышающие 100. Определить максимальное число в последовательности. Вывести это число.

Показать ответ
Ответ:
Popopoghdhz
Popopoghdhz
14.10.2020 17:23

1)

var

 a,i,count:integer;

begin

 readln(a);

 count:=0;

 for i:=1 to a do  

   begin

     readln(a);

     if a mod 13 = 0 then

       inc(count);

   end;

 writeln('Count: ',count);

end.

2)

var

 a,i,max:integer;

begin

 readln(a);

 for i:=1 to a do  

   begin

     repeat

       readln(a);

       if a>100 then

         writeln('Error.Repeat');

     until a<=100;

     if i = 1 then

       max:=a

         else

           if max < a then

             max:=a;

   end;

 writeln('Max: ',max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота