На вход программе подается строка (длиной не более 200 символов), в которой нужно зашифровать все английские слова (словом называется непрерывная последовательность английских букв, слова друга от друга отделяются любыми другими символами, длина слова не превышает 20 символов). Строка заканчивается символом #, других символов # в строке нет. Каждое слово зашифровано с циклического сдвига на длину этого слова. Например, если длина слова равна K, каждая буква в слове заменяется на букву, стоящую в английском алфавите на K букв дальше (алфавит считается циклическим, то есть, за буквой Z стоит буква A). Строчные буквы при этом остаются строчными, а прописные – прописными. Символы, не являющиеся английскими буквами, не изменяются. Требуется написать программу, которая будет выводить на экран текст зашифрованного сообщения. Например, если исходный текст был таким: Day, mice. "Year" isamistake# то результат шифровки должен быть следующий: Gdb, qmgi. "Ciev" ku b tpzahrl# (Написать прогу на ПАСКАЛЕ, заранее
1-й этап
Дано:
а — сумма, получаемая продавцом с продажи каждой из первых 50 газет;
1,2 ⋅ а — сумма, получаемая продавцом с продажи каждой из последующих газет.
Найти:
s — общую сумму, которую получит продавец с продажи 200 газет.
2-й этап
Для нахождения s можно вычислить значение следующего выражения:
50 ⋅ а + 150 ⋅ 1,2 ⋅ а.
Здесь а и s — величины вещественного типа.
3-й этап
Блок-схема
4-й этап
program n_12_63;
var a, s: real;
begin
writeln (‘Подсчет заработка продавца’);
writeln (‘Ввод а‘);
readln (a);
s:=50*a+150*1.2*a;
writeln (‘Продавец заработал ‘, s,’ руб.’)
end.
5-й этап
Протестировать программу можно по следующим данным:
а = 1,
s = 230.
Объяснение:
1. 01100011
2. 10111001
3. 1000000000011100
Объяснение:
Для получения внутреннего представления беззнакового целого числа надо перевести число в двоичную систему счисления и дополнить полученный результат слева нулями до указанной разрядности.
При представлении со знаком самый старший (левый) разряд отводится под знак числа. Если число положительное, то в знаковый разряд помещается 0 , если число отрицательное - 1.
1. 99 в 8-разрядной ячейке
99 / 2 = 49 + остаток 1
49 / 2 = 24 + остаток 1
24 / 2 = 12 + остаток 0
12 / 2 = 6 + остаток 0
6 / 2 = 3 + остаток 0
3 / 2 = 1 + остаток 1
1 / 2 = 0 + остаток 1
записываем остатки снизу вверх
99 в 10 СС = 1100011 в 2 СС
01100011
2. -57 в 8-разрядной ячейке
57 / 2 = 28 + остаток 1
28 / 2 = 14 + остаток 0
14 / 2 = 7 + остаток 0
7 / 2 = 3 + остаток 1
3 / 2 = 1 + остаток 1
1 / 2 = 0 + остаток 1
записываем остатки снизу вверх
57 в 10 СС = 111001 в 2 СС
10111001
3. -28 в 16-разрядной ячейке
28 / 2 = 14 + остаток 0
14 / 2 = 7 + остаток 0
7 / 2 = 3 + остаток 1
3 / 2 = 1 + остаток 1
1 / 2 = 0 + остаток 1
записываем остатки снизу вверх
28 в 10 СС = 11100 в 2 СС
1000000000011100