В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
umidmadrimow580
umidmadrimow580
03.11.2021 12:17 •  Информатика

На вход программе подается последовательность чисел от 1 до 9, заканчивающаяся нулем. Всего будет введено не более 100000 чисел. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т.д. и выдайте результат. В выходных данных всегда должно быть 9 чисел. Решить в Python.

Показать ответ
Ответ:
mirt10
mirt10
16.04.2021 14:29

a = [0]*9

while True:

 x = int(input('Введите цифру от 1 до 9: '))

 if x == 0: break

 if 1 <= x <= 9: a[x-1]+=1

for i in enumerate(a):

 print(f'{i[0]+1}: {i[1]}')

0,0(0 оценок)
Ответ:
Natasha2910
Natasha2910
16.04.2021 14:29

count = 0

m = [0]*9

while count <= 100000:

   a = int(input())

   if a == 0:

       break

   elif 1 <= a <= 9:

       m[a-1] += 1

   count += 1

   

print(*m)  #

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота