В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dima0354888
dima0354888
01.11.2021 03:04 •  Информатика

На вход программе подаётся непустая последовательность целых чисел оканчивающаяся отрицательным числом. Написать программу, которая подсчитает среднее арифметическое этих чисел. Последнее введённое число участвует в получении среднего арифметического. Точность выводимого числа не задаётся.
Входные данные
1 3 4 -1
Выходные данные

Показать ответ
Ответ:
alex06062
alex06062
14.10.2020 13:00

sr = 0

a = 0

k = 0

while a >= 0:

 a = int(input())

 k += 1

 sr += a

print(sr/k)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота