Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
krikstoon1
28.02.2020 14:50 •
Информатика
На вход программе подается количество битов.составьте программу ,которая переводит биты в байты ,килобайты,мегабайты,гигабайты.заранее ! )
Показать ответ
Ответ:
Alishan060606
27.08.2020 14:07
Program bity;
var a, b, c, d, e: real;
begin
write ('Введите количество бит: ');
read (a);
b:=a/8;
c:=b/1024;
d:=c/1024;
e:=d/1024;
writeln ('Это столько байт: ', b:8:4);
writeln ('Это столько килобайт: ', c:8:4);
writeln ('Это столько мегабайт: ', d:8:4);
write ('Это столько гигабайт: ', e:8:4);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Lootfarm
04.05.2021 14:30
Программа запрашивает у пользователя некое положительное число N, затем пользователь N раз вводит число (в диапазоне от 0 до 100) и программа выводит на экран среднее арифметическое...
ника11082001
10.10.2020 08:02
, ответить на вопросы по информатике. Тема: Поиск элемента с заданными свойствами ....
SofyaA3
26.01.2021 03:58
Отгадайте, название какого города зашифровано на рисунке, если известно, что все часы показывают послеобеденное время и название записано буквами....
078901234567
29.08.2022 23:11
Написать программу в turbo pascal. напишите программу генератором случайных чисел генерируется последовательность 50-ти случайных чисел из диапазона [-10; 20]. вычислить сумму положительных...
ramazanovmagomed
16.02.2022 19:03
1. How many Washingtons are there in the USA? 2. Where is the state Washington situated? 3. Where is the capital city Washington located? 4. When was the city founded? 5. Why do many...
emilityan
20.12.2022 08:46
Прямые m и n лежат в параллельных плоскостях α и β. Могут ли эти прямые быть: а) параллельными; б) скрещивающимися?...
vykvyk005oxq5pm
20.12.2022 08:46
Соедините города с достопримечательностями...
Клевая401
20.12.2022 08:46
Перемножте вирази а(2а+3)...
Николо223
20.12.2022 08:46
Докажите тождедство. (Задание на фото) ...
НосочекСудьбы
31.03.2021 05:35
Английский язык 10 класс...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var a, b, c, d, e: real;
begin
write ('Введите количество бит: ');
read (a);
b:=a/8;
c:=b/1024;
d:=c/1024;
e:=d/1024;
writeln ('Это столько байт: ', b:8:4);
writeln ('Это столько килобайт: ', c:8:4);
writeln ('Это столько мегабайт: ', d:8:4);
write ('Это столько гигабайт: ', e:8:4);
end.