В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
yulyatimonen
yulyatimonen
25.10.2021 03:42 •  Информатика

На С++ Седловые точки В двумерном массиве размерностью n×m, все элементы которого различны, требуется найти такие элементы, которые одновременно являются минимальными в своей строке и максимальными в своем столбце.

Входные данные

В первой строке входных данных находятся натуральные числа n,m≤100. В следующих n строках входных данных расположены по m натуральных чисел, не превосходящих 10000.

Выходные данные

Выведите пары индексов искомых элементов, каждую в отдельной строке. Нумерация строк и столбцов начинается с единицы. Если искомых элементов нет, то выведите 0.

Показать ответ
Ответ:
Lakensssss
Lakensssss
18.10.2021 10:48

картинка это 3 этап

1-й этап

Дано:

(40 − а) — количество проданных авиабилетов бизнес-класса по цене хрублей за билет;

(120 − b) — количество проданных авиабилетов экономического класса по цене х/2 рублей за билет.

Найти:

s — общую сумму, полученную компанией от продажи билетов за рейс.

2-й этап

Для нахождения s можно вычислить значение следующего выражения:

(40 − а) * х + (120 − b) * х/2.

Здесь а и b — целые величины, s — величина вещественного типа.

3-й этап

1-й этап

Дано:

(40 − а) — количество проданных авиабилетов бизнес-класса по цене хрублей за билет;

(120 − b) — количество проданных авиабилетов экономического класса по цене х/2 рублей за билет.

Найти:

s — общую сумму, полученную компанией от продажи билетов за рейс.

3-й этап

4-й этап

program n_13_63;

var a, b: integer; s, x: real;

begin

writeln (‘Подсчет суммы от продажи билетов’);

writeln (‘Количество а непроданных билетов бизнес-класса’);

readln (a);

writeln (‘Количество b непроданных билетов экономического класса’);

readln (b);

writeln (‘Стоимость билетов бизнес-класса х‘);

readln (x);

s:=(40−a)*x+(120−b)*x/2;

writeln (‘Билетов продано на ‘, s,’ руб.’)

end.

5-й этап

Протестировать программу можно по следующим данным:

а = 39,

b = 119,

х = 2000,

s = 3000.


УМОЛЯЮ НУЖНО ОЧЕНЬ В ИНФЕ ВООБЩЕ НЕ ШАРЮ ЕСЛИ НЕ СЛОЖНО, ТО С ОБЪЯСНЕНИЕМ. В аэробусе вмещающем 160
0,0(0 оценок)
Ответ:
Алкадиеныч
Алкадиеныч
13.10.2020 04:41

Векторная графика представления объектов и изображений (формат описания) в компьютерной графике, основанный на математическом описании элементарных геометрических объектов, обычно называемых примитивами, таких как: точки, линии, сплайны, кривые Безье, круги и окружности, многоугольники.

Объекты векторной графики являются графическими изображениями математических объектов.

Термин «векторная графика» используется для пояснения различий от растровой графики, в которой изображение представлено в виде графической матрицы.

При выводе на матричные устройства отображения (мониторы) векторная графика предварительно преобразуется в растровую графику, преобразование производится программно или аппаратно средствами современных видеокарт.

Растровое изображение (лат. rastrum — грабли) — изображение, представляющее собой сетку (мозаику) пикселей — цветных точек (обычно прямоугольных) на мониторе, бумаге и других отображающих устройствах.

Важными характеристиками изображения являются:

Размер изображения в пикселях — может выражаться в виде количества пикселей по ширине и по высоте (800 × 600 px, 1024 × 768 px, 1600 × 1200 px и т. д.) или же в виде общего количества пикселей (так, изображение размером 1600 × 1200 px состоит из 1 920 000 точек, то есть примерно из двух мегапикселей);

Количество используемых цветов или глубина цвета (эти характеристики имеют следующую зависимость: {\displaystyle N=2^{k}}N=2^{k}, где {\displaystyle N}N — количество цветов, {\displaystyle k}k — глубина цвета);

Цветовое пространство (цветовая модель) — RGB, CMYK, XYZ, YCbCr и др.;

Разрешение изображения — величина, определяющая количество точек (элементов растрового изображения) на единицу площади (или единицу длины). Не путать с размером сетки изображения!

Растровую графику редактируют с растровых графических редакторов. Создаётся растровая графика фотоаппаратами, сканерами, непосредственно в растровом редакторе, а также путём экспорта из векторного редактора или в виде снимков экрана.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота