В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
olenina051
olenina051
13.12.2020 20:57 •  Информатика

На с++ напишите программу, которая вычисляет сумму элементов матрицы. входные данные в первой строке записаны через пробел размеры матрицы: количество строк n и количество столбцов m ( 1 ≤ n , m ≤ 100 ). в следующих n строках записаны строки матрицы, в каждой – по m натуральных чисел, разделённых пробелами. выходные данные программа должна вывести одно число – сумму элементов матрицы. примеры входные данные 4 5 1 2 3 4 5 6 12 8 9 10 11 12 12 14 15 16 17 18 12 20 выходные данные 207

Показать ответ
Ответ:
тооироь
тооироь
10.09.2020 13:20
//g++  5.4.0

#include <iostream>
#include <vector>
using namespace std;
int main()
{
    size_t N, M, sum{ 0 };
    cin >> N >> M;
    vector<vector<int>> v(N, vector<int>(M));
    for (size_t i = 0; i < N; ++i) {
        for (size_t j = 0; j < M; ++j) {
            cin >> v[i][j];
            sum += v[i][j];
            cout << v[i][j] << " ";
        }
        cout << endl;
    }
    cout << sum << endl;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота