В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
яна1765
яна1765
02.07.2020 15:40 •  Информатика

На Python

Выведите таблицу умножения n × n в виде списка равенств (n вводит пользователь). Сначала первый множитель устанавливается равным 1, а значение второго пробегает числа от 1 до n, затем первый множитель становится равным 2, и т. д. См. пример.

Формат ввода: вводится одно натуральное число n.

Формат вывода: выводится n2 строк в указанном формате. Ввод

Пример:

3

1 * 1 = 1

1 * 2 = 2

1 * 3 = 3

2 * 1 = 2

2 * 2 = 4

2 * 3 = 6

3 * 1 = 3

3 * 2 = 6

3 * 3 = 9

Показать ответ
Ответ:
mumina7
mumina7
27.10.2020 21:51
Если запись числа оканчивается на 8, то система счисления (далее - с/с) не может иметь основание меньше чем 8+1=9. В этой системе счисления представление числа 30 будет двухзначным (с одного разряда может быть представлено число, не превышающее 8, а двух разрядов достаточно для записи числа 9²-1=80, что превышает 30).

Двухзначное число может быть записано в с/с по основанию n следующим образом: na+b. По условию число оканчивается цифрой 8 и его значение равно 30. Получаем уравнение:
na+8=30 ⇒ na=22.
Раскладываем 22 на простые множители: 22=1х2х11
Решение уравнения в целых числах при условии n>8 дает два варианта ответов:
(n=11, a=2), (n=22, a=1).
Это порождает два числа: 28_{11}=18_{22}
Существует ли с/с по основанию n, в которой запись числа 30 будет одноразрядной?
Уравнение 8n=30 не имеет решений в целых числах, поэтому такой с/с не существует.
ответ: 30(10)=18(22)=28(11).
0,0(0 оценок)
Ответ:
khydyrov1404
khydyrov1404
06.01.2022 08:57
Var
  x,y:integer;
  vcp,dx,dy:real;
begin
  Write('Возраст Тани='); Read(x);
  Write('Возраст Мити='); Read(y);
  vcp:=(x+y)/2;
  dx:=x-vcp; dy:=y-vcp;
  Writeln('Средний возраст равен ',vcp);
  if dx>0 then begin
    Writeln('Таня старше среднего возраста на ',dx,' лет,');
    Writeln('а Митя младше среднего возраста на ',-dy,' лет.')
  end
  else
    if dx=0 then Writeln('Таня и Митя ровесники')
    else begin
      Writeln('Таня младше среднего возраста на ',-dx,' лет,');
      Writeln('а Митя старше среднего возраста на ',dy,' лет.')
    end
end.

Тестовое решение:
Возраст Тани=15
Возраст Мити=12
Средний возраст равен 13.5
Таня старше среднего возраста на 1.5 лет,
а Митя младше среднего возраста на 1.5 лет.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота