На python выручайте нужно прямо , иначе пропал
время шло, а алиса всё продолжала падать. делать ей было совершенно нечего, и она снова стала рассуждать вслух:
— дина будет скучать без меня (дина — это алисина кошка). надеюсь, ей не забудут налить вечером в блюдечко молока… дина, моя милая, как было бы хорошо, если бы ты была сейчас со мной! правда, мыши здесь, наверное, только летучие, но ведь они похожи на обыкновенных. — алиса зевнула — ей вдруг захотелось спать, совсем сонным голосом проговорила:
— едят ли кошки летучих мышек? — она повторяла свой вопрос снова и снова, но иногда и спрашивала:
— едят ли летучие мышки кошек?
— впрочем, если некому ответить, то не всё ли равно, о чём спрашивать, верно?
вообще-то дина разборчивая кошка. и летучих мышек она не ест, она с ними знакомится. но их много, со всеми не перезнакомишься. нужно как-то выбирать, например, представляться только мышке с номером, начинающимся с загаданной цифры.
напишите программу, которая выводит все числа последовательности, начинающиеся заданной цифрой k.
если некоторое число появлялось в последовательности более одного раза, то нужно вывести его только один раз.
порядок вывода значения не имеет.
формат ввода
в первой строке вам дается произвольная цифра k.
во второй строке дается последовательность из нескольких натуральных чисел, записанных через пробел.
формат вывода
несколько чисел записанных через пробел.
пример 1
ввод вывод
2
2 12 212 1212 21212
2 21212 212
пример 2
ввод вывод
3
1 4 7 10 13 16 19 22 25 28 31 34 37
37 34 31
пример 3
ввод вывод
2
2 12 22 12 2
22 2
#include <iostream>
using namespace std;
int main(){ cout << "Vvedute kol-vo ocenok" << endl;
int n,i,a,Four,Five; n = i = a = Four = Five = 0;
cin >> n;
for (i = 1; i <= n; i++) { cin >> a; if (a == 4){ Four++;} else if (a == 5) { Five++; } } if (Four > Five){ cout << "Four" << endl;} else if (Five > Four) { cout << "Five" << endl; } else { cout << "Equal"<< endl; } cout << "Kol-vo 4: " << Four << " Kol-vo 5: " << Five << endl; return 0;}