Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
psossl
08.06.2022 23:35 •
Информатика
На питонеитон. перевод из десятичной системы счисления в двоичную.
Показать ответ
Ответ:
bereza11
20.06.2022 23:12
#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int n,sum=0;
float y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
if (mass[i] >0 )
{
k++;
y=pow(mass[i],2);
cout<<y;
sum+=mas[i]
}
}
system("pause");
}
2)#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}
0,0
(0 оценок)
Ответ:
kril20101
18.09.2021 08:02
//я писал этот унылый код полтора часа. Полтора часа, Карл! Я слишком расслабился.
#include <iostream>
using namespace std;
int k=2;
bool StrangeSeq(int n){
if (k<n){
if(n%k==0){
cout<<"false";
return false;
}
k++;
StrangeSeq(n);
}
else
{
cout<<"true";
return true;
}
}
int main(){
int n;
cin>>n;
StrangeSeq(n);
cin.get();
cin.get();
}
0,0
(0 оценок)
Популярные вопросы: Информатика
xovancku
02.10.2022 23:53
Если обратный код целого числа x имеет указанный вид 111110012 , то чему будет равно его значение в десятичной системе счисления...
EvgeniaDymova
14.10.2020 19:11
Составить и записать алгоритм решения задачи в графическом и словесноформульном виде.Написать программу на языке Паскаль не могу понять как делать ...
10alinka01
11.02.2023 14:57
Составьте кроссворд из 15 вопросов на тему природы Земли...
Еденарог
11.02.2023 14:57
Ребята сегодня надо сдать Exercise 1 Вставьте артикль the, там где это необходимо 1. __ British Isles 2. ___ North Pole 3. ___ Moscow 4. ___ Everest 5. ___ Atlantic Ocean...
ксюня264
29.05.2023 11:52
(c) Напишите значение этих приборов, для чего они предназначены?1. Весы2. Линейка3. Рулетка4. Мерный цилиндр5. Термометр6. Гигрометр7. Телескоп8.Секундомер...
Пенелопа2189
28.03.2020 10:16
составить диалог про какоё нибудь видео на ютубе (не меньше 20 реплик)...
turgalieva18
20.12.2020 12:30
15мкс=с9мн=нв системе си ОЧЕНЬ...
spfpspfpspdps
30.01.2023 16:59
На Атлантическом побережье в результате переселений англичан было образовано:...
faas1501
29.10.2021 02:40
Q mht3. Зміну температури обчислюють за формулою( )а) с =—б) Q = стДtQB) m =aг) ДtCÁtQст...
Vesna06
28.09.2022 10:15
Нарисуйте словесный образ матери. Сопоставьте нарисованный вами образ с образом матери из прочитанного рассказа....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <cmath>
using namespace std;
void main()
{
int n,sum=0;
float y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
if (mass[i] >0 )
{
k++;
y=pow(mass[i],2);
cout<<y;
sum+=mas[i]
}
}
system("pause");
}
2)#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}
#include <iostream>
using namespace std;
int k=2;
bool StrangeSeq(int n){
if (k<n){
if(n%k==0){
cout<<"false";
return false;
}
k++;
StrangeSeq(n);
}
else
{
cout<<"true";
return true;
}
}
int main(){
int n;
cin>>n;
StrangeSeq(n);
cin.get();
cin.get();
}