В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Zizosia
Zizosia
11.11.2022 06:30 •  Информатика

(на питоне)
Напишите программу, которая вычисляет значение выражения. Вывести результат с 2-мя знаками после запятой.


(на питоне)Напишите программу, которая вычисляет значение выражения. Вывести результат с 2-мя знакам

Показать ответ
Ответ:
denis403
denis403
01.02.2022 23:40

from math import sqrt

def f(x, y, z):

  return round( (x + y + sqrt((x-y)**2 + 4*z**2)) / 2, 2)

print(f(1, 2, 3))

0,0(0 оценок)
Ответ:
nik1ado21
nik1ado21
01.02.2022 23:40

from math import *

x = int(input())

y = int(input())

z = int(input())

result = (x + y + sqrt((x-y)**2 + 4*z**2))/2

result = round(result, 2)

print(result)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота