В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
umka2345
umka2345
15.02.2022 12:19 •  Информатика

На питоне Напишите программу, которая генерирует список из N элементов в диапазоне от -100 до 100. Вывести список на экран. Удалить из
списка первый отрицательный элемент (если такого нет, то
ничего не удалять). Снова вывести список на экран.

Показать ответ
Ответ:
nadyushasemeni
nadyushasemeni
23.03.2020 15:41
#include <iostream>
#include <ctime>
using namespace std;
int main ()
{
setlocale (0,"russian");
srand (time(NULL));
unsigned short N,a=0,b=0;
cout << "Кол-во элементов массива: ";
cin >> N;
short *array=new short [N];
cout << "Случайный массив: ";
for (unsigned short i=0;i<N;i++)
{
array[i]=rand()%201-100;
cout << array[i] << ' ';
if (array[i]>=0) a++;
else b++;
}
cout << endl;
cout << "Кол-во положительных элементов: " << a;
cout << endl << "Отрицательных: " << b << endl;
system ("PAUSE");
return 0;
}
0,0(0 оценок)
Ответ:
JamesBond007007007
JamesBond007007007
26.05.2020 22:31
1)
program cgt;
var a:array[1..100,1..100]of integer;
s,n,m,i,j:integer;
begin
read(n,m);
s:=0;
for i:=1 to n do
for j:=1 to m do
read(a[i,j]);
for i:=1 to n do
begin
for j:=1 to m do
if(i mod 2=1)then s:=s+a[i,j];
end;
writeln(s);
end.
2)
program cgt;
var a:array[1..100,1..100]of integer;
n,m,i,j:integer;
s,p:real;
begin
read(n,m);
s:=0;
for i:=1 to n do
for j:=1 to m do
read(a[i,j]);
for i:=1 to n do
begin
p:=1;
if(i mod 2=0)then begin
for j:=1 to m do
begin
p:=p*(sin(a[i,j]*pi/180))/(cos(a[i,j]*pi/180));
end;
s:=s+p;
end;
end;
writeln(s);
end.
3)

program cgt;
var a:array[1..100,1..100]of integer;
n,m,i,j,max,x,y:integer;
begin
read(n,m);
for i:=1 to n do
for j:=1 to m do
read(a[i,j]);
max:=a[1,1];
for i:=1 to n do
if(i mod 2=1)then begin
for j:=1 to m do
if(a[i,j]>=max)then  begin
max:=a[i,j];
x:=i;
y:=j;
end;
end;
writeln(x,' ',y);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота