В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
klymova2006oz080r
klymova2006oz080r
08.03.2020 22:37 •  Информатика

На Питоне ! Напишите программу, которая будет считать суммы положительных и отрицательных чисел отдельно.

Пользователь будет вводить число, а программа будет проверять: если число больше нуля, то программа добавляет его к сумме положительных. Иначе, добавляет к сумме отрицательных.

Всего программа будет проверять 5 чисел, а после этого выводить два числа: сумму всех положительных чисел и сумму всех отрицательных.

Показать ответ
Ответ:
Здохненко0403
Здохненко0403
26.05.2021 20:20

s1 = 0

s2 = 0

for i in range(5):

   a = int(input())

   if a < 0:

       s1 = s1 + a

   elif a > 0:

       s2 = s2 + a

print(s1, s2)

Не забудь проставить табуляцию, знания любят пробелы съедать.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота