Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
SuperCatYT
30.11.2020 22:21 •
Информатика
На паскале разработайте программу запрашивающую у пользователя длины обеих катетов прямоугольного треугольника и выводящую на экран гипотенузу по формуле пифагора.
Показать ответ
Ответ:
wertyfaq
09.08.2020 11:58
// PascalABC.NET 3.2, сборка 1359 от 11.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var a,b:real;
Write('Введите через пробел длины катетов: '); Read(a,b);
Writeln('Длина гипотенузы равна ',sqrt(a*a+b*b))
end.
Пример
Введите через пробел длины катетов: 15.6 18
Длина гипотенузы равна 23.819319889535
0,0
(0 оценок)
Популярные вопросы: Информатика
marselk2
25.10.2022 01:16
Установи соответствие между изображениеми и названиями датчиков ...
TheDanilDid
05.04.2021 10:59
По форме представления человеком различают следующие виды информации: А) текстовую, числовую, графическую, табличную и прБ) научную, социальную, политическую, экономическую...
fafafafgaf6262
23.05.2022 12:43
Сколько нужно заплатить за электроэнергию, если потребитель в этом месяце Н кВт/ч состовляет 17,79 тенге . Составьте программу ОТ...
oytu
26.02.2021 22:23
Запиши в тетради функции кнопок показанных на рисунке 38 страница информатика пятый класс...
Artyr2017
13.06.2021 03:59
НУЖНО РАЗГАДАТЬ РЕБУСЫ...
Didei
14.03.2022 15:45
Растровый графический файл содержит черно-белое изображение с 16-ю градациями серого цвета размером 50х80 точек. Каков информационный объем этого файла в байтах?...
EveChan
24.04.2021 19:21
Наведіть одне одному свої міркування щодо доцільності створення власних функцію для обчислення значення виразів інформатика...
revenko816mailru
22.09.2022 12:56
В каких случаях алгоритм работает правильно закончите фразу алгоритм работает правильно, если...
ZhenyaKan11
09.05.2020 04:37
До іть розв язати задачі з інформатики 2 варіанти ів...
alenakoryakovaa
10.09.2021 00:04
Составить программу для вывода на экран произведения трех введенных чисел, если все они не равны нулю. в противном случае вывести на экран их сумму...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin
var a,b:real;
Write('Введите через пробел длины катетов: '); Read(a,b);
Writeln('Длина гипотенузы равна ',sqrt(a*a+b*b))
end.
Пример
Введите через пробел длины катетов: 15.6 18
Длина гипотенузы равна 23.819319889535