В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Motya232
Motya232
28.08.2021 05:24 •  Информатика

На паскале написать программу которая в последовательность чисел( натуральных), определяет сумму всех чисел кратных 4 и оканчивающихся на 6. программа получает на вход нат числа, признаком окончания ввода явл число 0. могу решить и сам, только нельзя на компе проверить. так что надеюсь на вас.

Показать ответ
Ответ:
matriza1979
matriza1979
07.07.2020 18:20
Var
  a: integer;
  s: longint;

begin
  s := 0;
  a := -32768;
  while a <> 0 do
  begin
    readln(a);
    if a <> 0 then
      if a mod 4 = 0 then
        if a mod 10 = 6 then s := s + a
  end;
  writeln('Сумма равна ', s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота