На паскале Для N чисел, заданных случайным образом [-25;20], подсчитать сумму и количество чётных чисел, кратных 3. Значение N ввести с клавиатуры. 1. Построить знаковую модель. 2. Составить блок-схему алгоритма. 3. Написать программу.
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016 type tBook=record author:string[30]; naim:string[50]; pages:integer; godizd:integer end; begin var f:file of tBook; Rewrite(f,'books.dat'); Writeln('Ввод данных по книгам'); var s1,s2:string; var i1,i2:integer; var book:tBook; repeat s1:=ReadlnString('Автор или * для окончания ввода:'); if s1<>'*' then begin s2:=ReadlnString('Название книги:'); i1:=ReadlnInteger('Количество страниц:'); i2:=ReadlnInteger('Год издания:'); (book.author,book.naim,book.pages,book.godizd):=(s1,s2,i1,i2); Write(f,book) end until s1='*'; Writeln('*** Ввод завершен ***'); f.Close end.
Тестовое решение Ввод данных по книгам Автор или * для окончания ввода: Жюль Верн Название книги: 80 тысяч километров под водой Количество страниц: 573 Год издания: 1951 Автор или * для окончания ввода: Сергей Лукьяненко Название книги: Дозор Количество страниц: 934 Год издания: 2004 Автор или * для окончания ввода: Жюль Верн Название книги: Властелин мира Количество страниц: 104 Год издания: 2011 Автор или * для окончания ввода: * *** Ввод завершен ***
2. Программа для выборки
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016 type tBook=record author:string[30]; naim:string[50]; pages:integer; godizd:integer end; begin var f:file of tBook; Reset(f,'books.dat'); var s:=ReadlnString('Автор книги:'); var y:=Readinteger('Год издания, не ранее:'); var k:=0; var book:tBook; while not f.Eof do begin Read(f,book); if (book.author=s) and (book.godizd>=y) then begin Writeln(book); Inc(k) end; end; if k=0 then Writeln('Таких книг не найдено'); f.Close end.
Тестовое решение Автор книги: Жюль Верн Год издания, не ранее: 2005 (Жюль Верн,Властелин мира,104,2011)
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016 begin var m:=ReadInteger('Количество элементов в массиве А (m):'); var n:=ReadInteger('Количество элементов в массиве B (n):'); var k:=ReadInteger('Позиция вставки k (1<k<m):'); if (k>1) and (k<m) then begin var a:=ArrRandom(m,1,99); Writeln('Массив A'); a.Println; var b:=ArrRandom(n,1,99); Writeln('Массив B'); b.Println; Writeln('Результат вставки'); (a[:k]+b+a[k:]).Println end else Writeln('Вы нарушили условие 1<k<m') end.
Тестовое решение Количество элементов в массиве А (m): 10 Количество элементов в массиве B (n): 6 Позиция вставки k (1<k<m): 4 Массив A 68 64 30 75 36 15 50 39 92 26 Массив B 56 68 97 30 95 63 Результат вставки 68 64 30 75 56 68 97 30 95 63 36 15 50 39 92 26
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
type
tBook=record
author:string[30];
naim:string[50];
pages:integer;
godizd:integer
end;
begin
var f:file of tBook;
Rewrite(f,'books.dat');
Writeln('Ввод данных по книгам');
var s1,s2:string;
var i1,i2:integer;
var book:tBook;
repeat
s1:=ReadlnString('Автор или * для окончания ввода:');
if s1<>'*' then begin
s2:=ReadlnString('Название книги:');
i1:=ReadlnInteger('Количество страниц:');
i2:=ReadlnInteger('Год издания:');
(book.author,book.naim,book.pages,book.godizd):=(s1,s2,i1,i2);
Write(f,book)
end
until s1='*';
Writeln('*** Ввод завершен ***');
f.Close
end.
Тестовое решение
Ввод данных по книгам
Автор или * для окончания ввода: Жюль Верн
Название книги: 80 тысяч километров под водой
Количество страниц: 573
Год издания: 1951
Автор или * для окончания ввода: Сергей Лукьяненко
Название книги: Дозор
Количество страниц: 934
Год издания: 2004
Автор или * для окончания ввода: Жюль Верн
Название книги: Властелин мира
Количество страниц: 104
Год издания: 2011
Автор или * для окончания ввода: *
*** Ввод завершен ***
2. Программа для выборки
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
type
tBook=record
author:string[30];
naim:string[50];
pages:integer;
godizd:integer
end;
begin
var f:file of tBook;
Reset(f,'books.dat');
var s:=ReadlnString('Автор книги:');
var y:=Readinteger('Год издания, не ранее:');
var k:=0;
var book:tBook;
while not f.Eof do begin
Read(f,book);
if (book.author=s) and (book.godizd>=y) then begin
Writeln(book);
Inc(k)
end;
end;
if k=0 then Writeln('Таких книг не найдено');
f.Close
end.
Тестовое решение
Автор книги: Жюль Верн
Год издания, не ранее: 2005
(Жюль Верн,Властелин мира,104,2011)
begin
var m:=ReadInteger('Количество элементов в массиве А (m):');
var n:=ReadInteger('Количество элементов в массиве B (n):');
var k:=ReadInteger('Позиция вставки k (1<k<m):');
if (k>1) and (k<m) then begin
var a:=ArrRandom(m,1,99); Writeln('Массив A'); a.Println;
var b:=ArrRandom(n,1,99); Writeln('Массив B'); b.Println;
Writeln('Результат вставки'); (a[:k]+b+a[k:]).Println
end
else Writeln('Вы нарушили условие 1<k<m')
end.
Тестовое решение
Количество элементов в массиве А (m): 10
Количество элементов в массиве B (n): 6
Позиция вставки k (1<k<m): 4
Массив A
68 64 30 75 36 15 50 39 92 26
Массив B
56 68 97 30 95 63
Результат вставки
68 64 30 75 56 68 97 30 95 63 36 15 50 39 92 26