В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dapmoney2p0c8c0
dapmoney2p0c8c0
11.06.2021 15:46 •  Информатика

На paskal напишите программу, которая вычесляет среднюю температуру воздуха за 10 дней, выведит на экран max и min значение температуры. данные вводятся с клавиатуры.

Показать ответ
Ответ:
Var A:array [1..10] of integer;
b,min,max,i:integer;
c:real;
begin
b:=0;
c:=0;
for i:=1 to 10 do readln(A[i]);
for i:=1 to 10 do b:=b+A[i];
c:=b/10;
min:=A[1];
max:=A[1];
for i:=1 to 10 do 
if A[i]<min then min:=A[i];
for i:=1 to 10 do 
if A[i]>max then max:=A[i];
writeln(c);
writeln(min);
writeln(max);
end.             
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота