В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
PhotoBelka
PhotoBelka
30.08.2020 05:59 •  Информатика

На массив в turbo pascal 1) определите ,на сколько отличается рост самого высокого и самого низкого учащегося в классе? 2) результаты переписи населения, которые хранятся в памяти компьютера. элемент массива -год рождения жителя. подсчитайте общее число жителей, родившихся раньше 1958 года. 3) с 8 до 20 часов температура воздуха измерялась ежечасно, и результаты измерения заносились в компьютер. известно, что в течение этого времени температура понижалась. напишите программу, определяющую, в котором часу была впервые отмечена отрицательная температура

Показать ответ
Ответ:
gatilovasofiya
gatilovasofiya
30.06.2020 13:58
Program gt;
var n,i,max,min:integer;
a:array[1..100]of integer;
begin
read(n);
{n-кол-во учащихся}
for i:=1 to n do
read(a[i]);
max:=a[1];
min:=a[1];
for i:=1 to n do
begin
if(a[i]>max)then max:=a[i];
if(a[i]<min)then min:=a[i];
end;
writeln(max,' ',min,'-росты')
max:=max-min;
writeln(max);
end.
2)
program gt;
var n,i,a,k:integer;
begin
read(n);
k:=0;
for i:=1 to n do
begin
read(a);
if(a<1958)then k:=k+1;
end;
writeln(k);
end.
3)
program gt;
var i,q,a,l:integer;
begin
for i:=8 to 20 do
begin
read(a);
if(a<0)then begin
q:=q+1;
if(q=1)then l:=i;
end;
end;
writeln(l);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота