В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ariadnaorekhova
ariadnaorekhova
15.03.2023 11:58 •  Информатика

На каждое задание нужно создать отдельный файл в Питоне и написать в нем программу. Все файлы сохранить в архив и отправить мне личным сообщением. В модуле re есть еще несколько функций для работы с регулярными выражениями. Одна из них – это split(pattern, string). Она работает также, как строковый метод split но делит принятую строку не по разделителю, а по шаблону.
Дан набор строк в которых могут содержаться числа в двоичной системе счисления:
'1 "Hey!" 10 "Stop that!" 11 "Your vest looks stupid" 100 101 110'
'1000 "Did you kick someone in the face today?" 1001 1010 "Will I be making dinner then?!" 1011 110'
'10000 "Nice Beard" 1111 "Are you wearing denim shorts?" 1110 1101'
''
1
Напишите функцию, которая принимает строку и возвращает сумму всех двоичных чисел, присутствующих в строке. Сумма должна быть в десятичной системе. Если в исходной строке чисел нет или передана не строка, то функция должна вернуть -1. (Для конвертации в десятичное число из строки используйте int(‘строка’, 2) здесь второй аргумент – это основание системы счисления из которой нужно провести преобразование)
Предположим, что существуют «чистые строки» - это строки, в которых есть только буквы и пробелы. Никаких других символов в них быть не должно. Написать программу, которая загрузит содержимое приложенного файла, «очистит» все строки, создаст файл Result.txt и запишет результат в этот файл.
Дана строка, в которой буква h встречается как минимум два раза. Разверните последовательность символов, заключенную между первым и последним появлением буквы h, в противоположном порядке.
Вход: In the hole in the ground there lived a hobbit
Выход: In th a devil ereht dnuorg eht ni eloh ehobbit

Показать ответ
Ответ:
riga04
riga04
13.08.2020 23:16

function F(x: real): real;

begin

 F := 3 * sin(x) + 2 * sqr(x) - 1;

end;

var

 a, b, h, x, Fa, Fx: real;

begin

 Write('Введите через пробел начало интервала, конец и шаг: ');

 Readln(a, b, h);

 x := a; Fa := F(a);

 repeat

   Fx := F(x);

   if Fx = 0 then Writeln('Найден корень ', x:0:3)

   else

   if Fx * Fa < 0 then

     Writeln('Найден интервал изоляции корня (', a:0:3, ';', x:0:3, ')');

   a := x; Fa := Fx; x := x + h

 until x > b;

end.

Тестовое решение:

Введите через пробел начало интервала, конец и шаг: 0 1.95 0.15

Найден интервал изоляции корня (0.150;0.300)

Введите через пробел начало интервала, конец и шаг: -5 5 0.1

Найден интервал изоляции корня (-1.500;-1.400)

Найден интервал изоляции корня (0.200;0.300)

Объяснение:

Лови! Удачки!
0,0(0 оценок)
Ответ:
NEW4IK
NEW4IK
31.08.2021 23:44

В программе MS Word создайте новый документ. Файл сохраните в папке класса с именем Фамилия.docx.

В созданный документ вставьте скриншот рабочего стола, в случае необходимости измените размер изображения, на вкладке Формат в группе Размер..

На вкладке Формат в группе Упорядочить выберите Обтекание текстом - Вокруг рамки , затем расположите рисунок в центре листа.

На вкладке Вставка в группе Иллюстрации выберите подходящие Фигуры и подпишите основные элементы Рабочего стола.

Объяснение:

доступно ? Это просто действия с компьютером и программой Microsoft Word. Единственное, что тут можно не знать, это как делать скриншот, и это кнопка 'Print screen'(на клавиатуре)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота