В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Давиденко
Давиденко
15.11.2020 01:16 •  Информатика

на кану оценка за четверть . нужно написать программу которая проверяет у тебя таблицу умножения, машина должна дать 10 примеров и показать результат. причём чтоб они не повторялись. мы должны вбивать в конце одно число. это ответ в каждом примере

Показать ответ
Ответ:
dianapodosenova
dianapodosenova
07.10.2020 04:45
Var
a,b,i,z:integer;
Begin
ClrScr;
Randomize;
for i:=1 to 10 do
 begin
 a:=random(9)+1;
 b:=random(9)+1;
 write(a,'*',b,' = ');
 readln(z);
 if z=a*b then writeln('Верно!')
 else  writeln('Не верно! ',a,'*',b,' = ',a*b);
 end;
readln;
end.

Пример (для 3 заданий):
6*6 = 36
Верно!
8*3 = 26
Не верно! 8*3 = 24
2*4 = 8
Верно!
0,0(0 оценок)
Ответ:
mihailgrand
mihailgrand
07.10.2020 04:45
Program z1;
Uses Crt;
Var
z:integer;
Begin
ClrScr;
writeln('1*2=?');
readln(z);
if z=2 then writeln('Верно!')
else  writeln('Не верно! 1*2=2');
writeln('2*3=?');
readln(z);
if z=6 then writeln('Верно!')
else  writeln('Не верно! 2*3=6');
writeln('3*6=?');
readln(z);
if z=18 then writeln('Верно!')
else  writeln('Не верно! 3*6=18');
writeln('4*7=?');
readln(z);
if z=28 then writeln('Верно!')
else  writeln('Не верно! 4*7=28'); 
writeln('5*9=?');
readln(z);
if z=45 then writeln('Верно!')
else  writeln('Не верно! 5*9=45');
writeln('6*4=?');
readln(z);
if z=24 then writeln('Верно!')
else  writeln('Не верно! 6*4=24');
writeln('7*7=?');
readln(z);
if z=49 then writeln('Верно!')
else  writeln('Не верно! 7*7=49');
writeln ('8*6=?');
readln(z);
if z=48 then writeln('Верно!')
else  writeln('Не верно! 8*6=48');
writeln('9*4=?');
readln(z);
if z=36 then writeln('Верно!')
else  writeln('Не верно! 9*4=36');
writeln('10*8=?');
readln(z);
if z=80 then writeln('Верно!')
else  writeln('Не верно! 10*8=80');
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота