В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

На basic составить программу нахождения наибольшего общего делителя и наименьшего общего кратного 2-х натуральных чисел.(нок(а, в) = а*в / нод (а,

Показать ответ
Ответ:
MUSIC555
MUSIC555
25.07.2022 03:26

Более простой вариант

from datetime import timedelta

 

music = {"mus1": 4.24,

       "mus2": 2.50,

       "mus3":  2.05}

time = timedelta(minutes=0, seconds=0)

maxcount = int(input("Сколько песен выбрать?: ")) + 1

count = 1

while 1:

       try:

               name = str(music[input(f"Название {count} песни: ")]).replace(".", " ").split()

               time = time + timedelta(minutes=int(name[0]), seconds=int(name[1]))

               count += 1

       except:

               print("Такой песни нету!")

               break

       if count == maxcount:

               print(f"Общее продолжительность песен: {int(time.total_seconds()%3600) // 60}.{int(time.total_seconds()%3600) % 60}")

               break

0,0(0 оценок)
Ответ:
tim1963yt
tim1963yt
25.07.2022 03:26

Через флаги:

violator_songs = [

['World in My Eyes', 4.86],

['Sweetest Perfection', 4.43],

['Personal Jesus', 4.56],

['Halo', 4.90],

['Waiting for the Night', 6.07],

['Enjoy the Silence', 4.20],

['Policy of Truth', 4.76],

['Blue Dress', 4.29],

['Clean', 5.83]

]

li = []

special_list = []

qty = int(input('Сколько песен выбрать? '))

print()

count = 1

ok = True

while ok:

   for _ in range(qty):

       if ok:

           song = input('Введите название ' + str(count) + ' песни: ')

           for elem in violator_songs:

               li.extend(elem)

               if song not in li:

                   print('Ошибка. Такой песни в плейлисте нет!')

                   ok = False

                   break

               else:

                   special_list.append(song)

                   count += 1

       summ = 0

       for i_time in violator_songs:

           if i_time[0] in special_list:

               summ += i_time[1]

   if ok:

       print('\nОбщее время звучания песен:', float(round(summ, 2)))

       break

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота