В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ivan01356
ivan01356
13.01.2023 05:28 •  Информатика

Михаил решил написать программу для принадлежности точек заданной области (на рисунке) в декартовой системе координат: Михаил забыл, как правильно ставить условия ему дописать программу (составь условие). С клавиатуры вводятся две координаты точки — x, y (целые числа). Необходимо определить, принадлежит эта точка к заштрихованной области или нет (сначала проверяем наклонную прямую, потом — вертикальную и горизонтальную):

( ) ( ) ( )


Михаил решил написать программу для принадлежности точек заданной области (на рисунке) в декартовой
Михаил решил написать программу для принадлежности точек заданной области (на рисунке) в декартовой

Показать ответ
Ответ:
masha3323
masha3323
01.11.2022 12:23
//Pascal ABC.NET v3.1 сборка 1172

Var
 f,s:text;
 st,sp:string;
 i:integer;
 c:char;
begin
 assign(s,'text1.txt');
 reset(s);
 while not Eof(s) do
 begin;
 readln(s,sp);
 st:=st+sp+chr(10)+chr(13);
 end;
 close(s);
 for i:=1 to length(st) div 2 do
  begin
   c:=st[i];
   st[i]:=st[length(st)-i+1];
   st[length(st)-i+1]:=c;
  end;
 assign(f,'text.txt');
 rewrite(f);
 write(f,st);
 close(f);
end.

Текст в файле text1.txt:

Simple text
1And another simple text
2New text

Текст в файле text.txt:
txet weN2
txet elpmis rehtona dnA1
txet elpmiS
0,0(0 оценок)
Ответ:
valeriya210322
valeriya210322
01.08.2021 07:00
1.
const n=20; 
var
  a:array[1..n] of integer;
  i,k,s:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
  a[i]:=Random(51)-25;
  Write(a[i]:4)
end;
writeln;
write('K = '); readln(k);
s:=0;
for i:=1 to n do 
 if a[i] mod k = 0 then s:=s+a[i];
Writeln('s = ',s);
end.

Пример:
Исходный массив:
18 -24 -4 -21 15 19 18 -16 -1 -8 7 -21 21 22 -24 -4 18 -16 24 4
K = 3
s = 24

2.
const n=10; 
var
  a:array[1..n] of integer;
  i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
  a[i]:=Random(11);
  Write(a[i]:4)
end;
writeln;
writeln('Выбранные элементы:');
for i:=1 to n do 
 if a[i]<=i then Write(a[i]:4) else write(' ':4);
Writeln;
end.

Пример:
Исходный массив:
   9   1   2   8   2   7   1  10   8   3
Выбранные элементы:
       1   2       2       1       8   3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота