В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Katyshkamya
Katyshkamya
09.11.2021 01:35 •  Информатика

Массив задан целыми числами: 14, 10, -8, 6, 12, 4, -16, -7, -16, -7, 5, 3. что будет напечатано по окончании работы программы? составить таблицу трассировки для программы: var k, i : integer; mas : array[1..10] of integer; begin k: =0; for i: =1 to 10 do if mas[i]< 10 then k: =k+1; write(k); end. 9 класс

Показать ответ
Ответ:
domaris246
domaris246
17.04.2021 17:14

Итак, целевой язык - C++. Это значит мы - радостные обладатели технологии потоков, с коей мы будем производить весь ввод/вывод как при работе с файлами, так и при работе со стандартным вводом/выводом (консолью).

Ну а раз уж мы работаем с потоками, то будем делать это красивенько: создадим класс-обёртку для потока ввода, цель которого - поиск в этом потоке цитат и отправка их на поток вывода (который мы передаём).

[!] Стоит отметить, что по заданию не сказано, что есть разница между ' и ". Поэтому будем считать их одинаковыми.

[!] Внимание! Рядом с исполняемым файлом надо создать текстовый файл data.txt c текстом и цитатами.

Код

С++11

#include <iostream>#include <fstream>using std::cout;class QuotesFinder {    std::istream &in_stream;    bool is_it_in_quote = false;public:    QuotesFinder() = delete;    QuotesFinder(QuotesFinder&&) = default;    QuotesFinder(QuotesFinder const&) = default;    explicit QuotesFinder(std::istream &is) : in_stream(is) {}    [[nodiscard]]    bool eof() const {        return in_stream.eof();    }    // Вот тут происходит вся магия    QuotesFinder& operator >> (std::ostream& out_stream) {        char buffer;        in_stream.get(buffer); //Получаем очередной символ из потока        if (buffer == '\"' || buffer == '\'') {            if (is_it_in_quote) {                is_it_in_quote = false;                out_stream << buffer;                out_stream << "\n";                return *this;            }            is_it_in_quote = true;        }        if (is_it_in_quote) {            out_stream << buffer;        }        return *this;    }};int main() {    std::ifstream file("data.txt");  // Открываем файл    if (!file.is_open()) {        cout << "File is not exits!";        return 1;    }    QuotesFinder finder(file);  // Создаём обёртку из файлового потока    while (!finder.eof()) // Пока не достигли конца потока        finder >> cout; // переправляем очередной кусок информации в поток вывода}
Написать программу на С++. Задача - Считать текст из файла и вывести на экран только цитаты, т. е. п
0,0(0 оценок)
Ответ:
zzzzzzya2017
zzzzzzya2017
16.07.2021 15:35

У человека есть 5 органов чувств

глаза (зрение),

уши (слух),

язык (вкус),

нос (обоняние)

кожа (осязание, ощущение боли, температуры)

горячий хлеб влияет на глаза, язык, обоняние, кожу. если его нюхать, то будет запах, если смотреть на него, то его пар может попасть в глаза, ну и остальное ясно

во время сна наши глаза закрыты и мы ничего не видим, уши продолжают слышать, потому что от громкого звука и т.п. человек может проснуться, язык и нос также реагируют на различные вещи, кожа безусловно, тоже чувствует прикосновения

замороженная роза воздействует на кожу, если держать ее, то кожа станет холоднее, если облизать языком, то будет также холодно, на уши никак не влияет, глазами мы видим, запах по сути не передает

река мокрая, может воздействовать на глаза, кожу, язык, потому что влажно. уши (если нырнуть в реку, то слышать будем приглушенно), ну река бывает пахнет, но это не всегда.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота