В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
elina184
elina184
29.03.2021 23:34 •  Информатика

Массив r[1]=12, r[2]=3, r[3]=-5, r[4]= -6, r[5]=4, r[6]=9, r[7]=0, r[8]=8. определите значение суммы после выполнения следующего фрагмента программы: sum: =0; for i: =3 to 7 do if r[i]> 5 sum: =sum+r[i]; writeln (sum);

Показать ответ
Ответ:
asiper4ik
asiper4ik
07.10.2020 07:57
// PascalABC.NET 3.3, сборка 1576 от 16.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:array of integer := (0,12,3,-5,-6,4,9,0,8);
var sum:= 0;
for var i := 3 to 7 do
 if a[i]>5 then
 sum:=sum+a[i];
 writeln (sum);
end.

ответ: 9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота