Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
ikstar
11.06.2021 22:27 •
Информатика
Массив объявлен следующим образом:
Var a: array[1..5] of integer
При каких значениях х программа завершается аварийно?
Write (A[x+3])
Показать ответ
Ответ:
Ram543
13.12.2020 06:29
While (tnum != 0) //tnum, tden - числитель и знаменатель искомой дроби
{
if (tnum < tden)
{
temp = tnum;
tnum = tden;
tden = temp;
}
tnum = tnum - tden;
}
gcd = tden; //вычисляем наибольший общий делитель
numerator = numerator / gcd; //делим числитель и знаменатель на
НОД, получаем сокращенную дробь
denominator = denominator / gcd;
0,0
(0 оценок)
Ответ:
evgenijpetrov
08.03.2023 07:22
Vara,b,c,d,x1,x2: real;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
enotnana
30.01.2022 09:38
В программе «:=» обозначает оператор присваивания, знаки «+,-, *, /», - соответственно операции сложения, вычитания, умножения и деления. Правила выполнения операций и порядок...
protivnuy
05.12.2021 18:37
Ребята бабушке собирать малину. Катя собрала n литров, Саша - m литров, а Юра - k литров. Определить процент ягоды, собранной Юрой с точность до двух знаков после запятой. Никто...
KrutoiYurka2008
24.02.2023 22:49
с заданием по информатике...
каринп4
12.02.2023 20:14
1. Ученик продиктовал своей маме по телефону IP-адрес, мама его записала так: 2574125136. В ответе запишите IP-адрес с разделительными точками. 2.На месте преступления были обнаружены...
TonyaOgneva
04.02.2021 11:13
с заданиями по информатике 1)Дана программа: Python s = int(input()) t = int(input()) if s 10 or t 10: print( ДА ) else: print( НЕТ ) Pascal var s,t: integer; begin readln(s);...
Топовыйшкольник
23.04.2022 08:23
Даны числа 4 45 342 1472 10969 Используя MS Excel, вычисли среднее арифметическое данных чисел....
лимон2509
28.02.2023 13:20
Ребят, что не так в программе? Надо чтобы выводило треугольником, вот так: * ** *** А выводит в столбик зачем-то...
новичок586
20.11.2022 04:23
Какая формула будет получена при копировании в ячейку Е 4, формулу из ячейки Е...
DarkoRei
17.04.2023 14:01
КУМИР 7. Составьте программу закрашивания указанных клеток с использованием цикла для. Начальное положение Робота отмечено символом ◊....
HALERIOP
15.01.2022 14:40
Когда электронная почта получила рас в России...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
{
if (tnum < tden)
{
temp = tnum;
tnum = tden;
tden = temp;
}
tnum = tnum - tden;
}
gcd = tden; //вычисляем наибольший общий делитель
numerator = numerator / gcd; //делим числитель и знаменатель на
НОД, получаем сокращенную дробь
denominator = denominator / gcd;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.