В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Массив c заполнен случайным образом целыми числами . найти среднее арифметическое из квадратов данной последовательности.решить в vba(visial vasic)​

Показать ответ
Ответ:
meruert2001n1
meruert2001n1
24.04.2020 09:50

Ветвление – это команда алгоритма, в которой делается выбор, выполнять или не выполнять какую-нибудь группу команд в зависимости от условий. Ветвление используется в двух случаях:

Когда в алгоритме есть действия, которые иногда нужно пропускать (в зависимости от какого-то условия).

Когда в алгоритме нужно записать выбор  тех или иных действий (в зависимости от какого-нибудь условия).

В блок-схеме условие ветвления записывается в ромбе, из которого выходят обязательно 2 стрелки. Стрелка «Да» указывает на команды, которые должны выполняться, когда условие соблюдается. Стрелка «Нет» указывает на команды, которые должны выполнятся, когда условие не соблюдается.

0,0(0 оценок)
Ответ:
костелои
костелои
27.12.2021 20:09

Пример на продукте - бананы

program v1;

var m,n,sum,t:integer;

st1:string[10];

 begin

   sum:=0; t:=0;

   writeln('Здравствуйте');

   writeln('Банан красного цвета стоит 2500, банан синего цвета стоит 3000, банан черного цвета стоит 3700');

   writeln('Сколько купите бананов '); readln(n);

  writeln('Введите цвет бананов '); readln(st1);

   if (st1='Красного') or (st1='красного') or (st1='Красный') or (st1='красный') then sum:=3000*n;

   if (st1='Синего') or (st1='синего') or (st1='Синий') or (st1='синий') or (st1='Синей') or (st1='синей')  then sum:=2500*n;

   if (st1='Черного') or (st1='черного') or (st1='Чёрного') or (st1='чёрного') or (st1='Черный') or (st1='черный') or (st1='чёрный') or (st1='Чёрный')  then sum:=3700*n;

   writeln('Сумма покупки ', sum);

   writeln('Введите сумму'); readln(m);

   t:=m-sum;

   writeln('Возьмите сдачу ',t);

   writeln('Всего доброго, приходите еще');

 end.


Дорогие программисты по информатике! Напишите программу по этим алгоритмам умоляю
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота