Массив a из n целых чисел. требуется вывести только неотрицательные числа. формат входных данных на первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве. на следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива. формат выходных
данных требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле. с++. мы только недавно изучили без всяких примудростей. желательно с
Задача 1
program z1;
var n,a,i,k:integer;
begin
write ('Введите количество чисел: ');
read (n);
for i:=1 to n do
begin
write ('Введите число: ');
read (a);
if a = 0 then k:=k+1
end;
writeln('Количество нулей среди чисел: ',k)
end.
Задача 2
program z2;
var n,a,i,m:integer;
begin
write ('Введите количество чисел: ');
read (n);
for i:=1 to n do
begin
write ('Введите число: ');
read (a);
if i = 1 then m:=a;
if a > m then m:=a
end;
writeln('Максимальное число среди чисел: ',m)
end.
или
program z2;
var n,i,m:integer;
a:array[1..100] of integer;
begin
write ('Введите количество чисел (n<=100): ');
read (n);
for i:=1 to n do
begin
write ('Введите число: ');
read (a[i]);
if i = 1 then m:=a[i];
if a[i] > m then m:=a[i]
end;
writeln('Максимальное число среди чисел: ',m)
end.
Вычти квадрат и возведи
Объяснение:
Первая из них уменьшает число на экране на 1, вторая возводит его во вторую степень. Исполнитель работает только с натуральными числами. Составьте алгоритм получения из числа 2 числа 64, содержащий не более 5 команд. В ответе запишите только номера команд. (Например, 11121 — это алгоритм: вычти 1, вычти 1, вычти 1, возведи в квадрат, вычти 1, который преобразует число 7 в 15.) Если таких алгоритмов более одного, то запишите любой из них.