В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Sharjnik
Sharjnik
16.11.2022 16:28 •  Информатика

Манхэттенский проект — кодовое название программы сша по разработке ядерного оружия. в разработке участвовало рекордное количество ученых с мировым именем. вот список наиболее известных из них: энрико ферми, нильс бор, джон фон нейман, ричард фейнман, роберт оппенгеймер, ганс бизе, ханс бете. вам было поручено написать программу-пропуск, которая принимает на вход имя человека и выводит "доступ разрешен", если имя присутствует в списке, представленном выше, или "доступ запрещен" в обратном случае.

нужно использовать переменную elif

Показать ответ
Ответ:
IKarapuzikI
IKarapuzikI
06.10.2020 23:44

#include <iostream>  

#include <string>  

#include <conio.h>

 

   #define ESC 27

 

using namespace std;

 

int main() {

   char ch;

   int sum = 0;

   do {

       ch = _getch();

       if (ch == ESC) {

           cout << "Output of the program:\n" << sum;

           putchar('\n');

       } else {

           cout << ch;

           sum += (int)ch;

           putchar('\n');

       }

   } while (ch != ESC);

   system("pause");

   return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
Diankao4ka
Diankao4ka
18.07.2022 14:55

Электромагнитті сәулелердің адам ағзасына әсері

  Жаңа білім

  Электромагнит өрісі – материяның ерекше түрі және оның көмегімен электрлік зарядталған бөлшектер өзара әрекетке түседі. Жұмыс істеп тұрған электр құрылғылар молекула, электрондар мен иондарды, атомдарды қозғалысқа әкеледі. Адамның жасушалары да молекулалардан тұратынын ескерсек, күшті электрмагнит ағзада жасуша молекулаларының тербелісін, қозғалысын тудырады. Осындай қозғалыс ағза жасушаларының жағымсыз өзгерістеріне алып келеді.

​   Біз күнделікті өмірде қолданатын электр құралдардың денсаулығымызға қаншалықты зиян келтіретінін кейде білмей де қаламыз. Электромагниттік толқындар кез келген үйде, мекемеде жалпы адам өмір сүретін барлық ортада бар. Электромагниттік толқындарды тұрғын үйдің теледидарында, үтікте, мұздатқышта, микротолқынды пеште, шаңсорғышта, компьютерде, ұялы телефонда да болады.

​   Электромагниттік өрістер барлық тіршілік көздеріне, оның ішінде адам ағзасына өте үлкен зардап тигізеді. Биологиялық және медициналық зерттеу нәтижелері көрсеткендей, электромагниттік өрістердің адамның жүйке жүйесіне, ішкі мүшелеріне, физиологиялық дамуына тигізетін теріс зардаптары анықталған. Сонымен қатар, кейінгі кезде шетел мамандарымен бірігіп өткізілген зерттеулер нәтижелеріне сүйенетін болсақ, онда электромагниттік өрістердің әсерінен жүздеген ауру түрлерінің жаппай таралуы анықталып, қалаларда өзіне қол жұмсау фактілері көптеп тіркелген. Себебі, электромагниттік өрістер адамның ми құрылысына өте қатты әсер ете отырып, дұрыс ойлау, есте сақтау қабілетін бұзады. Электр құрылғыларының электромагниттік сәуле шығарудың өзіндік қалыптасқан нормалары бар (1-кесте).

1-кесте. Электромагниттік сәуле шығару нормасы

  Компьютердің электромагниттік толқындарының адам ағзасына тигізер әсері өте көп.

​   Негізінен, компьютердің алдында отырып, жұмыс істейтіндердің шағымданатын сырқат белгілері екі топқа бөлінеді:

Көздің көру қабілетінің нашарлауы.

Бастың желке тұсының (қарақұсының), мойын мен иық, жауырын, білектің ауыруы. Көру қабілетінің нашарлауы, оның бұлдырлап, анық көрмеуі, көзіне түскен салмақтан күйген тәрізді ашып, қызаруы. Мамандар оны компьютерлік көру қабілетінің синдромы деп атайды. Дәрігерлердің айтуынша, компьютерлік көру қабілетінің синдромдары уақытша рефракцияның нашарлауына немесе күшеюіне, аккомодация көлемінің кішіреюіне, қарама-қарсылық сезімталдығының, сезіну қабілетінің әлсіреуіне әкеліп соқтырады.

  Компьютерден таралатын электромагниттік толқынның адам ағзасына залалы, тигізетін зиянды факторлары мынадай:

  көздің көру қабілетін төмендетеді;

  омыртқаның қисаюына әкеледі;

  жүйкеге салмақ түсіреді;

  адам тез шаршап, денені әлсіздік басады;

  иммунитет төмендейді, адам көп отырған кезде қан айналымы бәсеңдейді.

  Осындай ауруларға шалдыққың келмесе, компьютердің алдында көп отырмауға тырыс, ал егер жұмыс бабымен талап етілсе, арнайы ережелерді сақтап, жаттығу жасап отыру қажет. Өз денсаулығыңа көп көңіл бөлгенің жөн.

Тағы да осы тақырып бойынша Басқа іс-әрекеттер

  Компьютер экранының электромагниттік сәулеленуінің әсері

  Жұмыс iстеуге отырғанда, сағат сайын демалыс ұйымдастырып, жаттығулар жасап отыру керек. Ноутбукты тiзе үстiне алып отыруға болмайды. Күштi радиация тарайтындықтан, бедеу болып қалу қаупi бар. Компьютерде, ноутбукта отырғанда, көзге қорғаныс көзiлдiрiгiн кию қажет. Мысалы, суға түсiп келгеннен кейiн компьютердiң алдында отыру радиацияны қабылдау мөлшерiн азайтады екен. Компьютер, ноутбук сатып аларда «S» белгiсiнің бар-жоғына қарау керек. Бұл белгi – компьютерде, ноутбукта радиацияға қарсы қорғаныстың бар екенiнiң дәлелi. Есіңде болсын, компьютердiң жанына немесе артына отыруға болмайды, оның радиацияны ең көп тарататын бөлiгi – сол тұстары.

  Компьютердi орналастырғанда, артқы жағын терезеге немесе қабырға жаққа қаратқан жөн, одан таралған радиация сыртқа кетедi. Компьютерден, ноутбуктан жылы бу шығады, оның әсерiнен адам ағзасындағы кальций мөлшерi азаяды. Соның салдарынан тырнақ – сынғыш, шаш – түскiш келедi. Компьютер, ноутбук, теледидар және басқа да тұрмыстық заттар орналасқан бөлмелерде мүмкiндiгiнше пластик терезелерге қарағанда ағаш терезелер болғаны дұрыс. Себебi, бөлмедегi радиацияны пластик терезе сыртқа шығармай, тосқауыл болады.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота