Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Julianovikova6
19.05.2023 14:45 •
Информатика
Люди добрые, на ! вычислить в паскаль: 1. y = x - x³\3 + x⁵\52. y = 2⁻ˣ - cosx + sin (2xy)3. y = x²-7x+10\x²-8x+124. y = x - 10sinx + | x⁴ - x⁵ |нужно написать коды программ и результаты их работы
Показать ответ
Ответ:
artem16021artemka16
09.10.2020 21:35
program task31177829;var y: real; x: integer;begin Writeln('ПЕРВОЕ ЗАДАНИЕ: '); Readln(x); y := x - (Power(x, 3)/3) + (Power(x, 5)/5); Writeln('Y = ', y); Writeln('ВТОРОЕ ЗАДАНИЕ: '); // если здесь всё-таки sin(2*x*y), то пишем Sin(2*x*y) // в таком случае оно возьмёт значение y из предыдущих расчётов Readln(x); y := Power(2, -x) - Cos(x) + Sin(2*x); Writeln('Y = ', y); Writeln('ТРЕТЬЕ ЗАДАНИЕ: '); Readln(x); y := (Power(x, 2) - 7*x + 10)/(Power(x, 2) - 8*x + 12); Writeln('Y = ', y); Writeln('ЧЕТВЁРТОЕ ЗАДАНИЕ: '); Readln(x); y := x - 10*Sin(x) + Abs(Power(x, 4) - Power(x, 5)); Writeln('Y = ', y);end.
во втором примере синус принимает переменную Y как значение? если так, то на 14 строке измените на:
y := Power(2, -x) - Cos(x) + Sin(2*x*y);
0,0
(0 оценок)
Популярные вопросы: Информатика
mehemmed20039
17.07.2021 13:24
Определи значение переменной b после выполнения данного алгоритма: b: =5 a: =-3 a: =7+a*b b: =a/2+b в ответе укажите одно целое число - значение переменной b....
olegtab34
17.07.2021 13:24
Укажите сумму всех положительных десятичных чисел, не превосходящих 35, запись которых в системе счисления с основанием 5 оканчивается на 11....
Khidjana95
24.11.2020 18:28
На двери деканата злоумышленники масляной краской нарисовали несколько карикатур на преподавателей. подозрение пало на известных хулиганов и вольнодумцев пашу и...
propprap
21.02.2021 10:07
Какого размера будет файл рисунка размером 40×30 пикселей в режиме истинного цвета (ответ дать в байтах). При кодировании с палитрой 256 цветов? При кодировании...
alesyabogun135
13.01.2023 00:33
Разшифруйте текст: arei/5ery sfdlDdhft dcreRegde edos9rfgc bxp.lffxx ikmchdcct keeodterd lqfmfgzxc...
vstef
15.09.2022 11:03
Определи, о каком этапе решения задачи на ЭВМ идёт речь. • анализ существующих аналогов;• анализ технических и программных средств;• разработка математической модели;•...
egorstorozhenk
26.02.2023 17:25
Це оцъыз рсеюш жецш, 9. Каждой букве алфавита поставлена в соответствие пара чиселпервое числономер столбца, а второе — номер строки следующей кодовой таблицы: ...
risj83risj
23.02.2021 08:55
Выражения : 1)1+a*0 2)x*x*1 3)0*x+0 4)0+x*1 5)f=не x и (не(не y или x)) 6)f=не (x и (не x и не y)) 7)f=не x или (не(x и y и не y))...
Markys1555
10.05.2021 11:59
Решите неравенство (х-4)^2 *меньше* √6 (х-4)...
vladlena24
10.05.2021 11:59
Из каких материалов изготавливают ударные инструменты? скажите важно и ! !...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
во втором примере синус принимает переменную Y как значение? если так, то на 14 строке измените на:
y := Power(2, -x) - Cos(x) + Sin(2*x*y);