В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Pipidastet
Pipidastet
03.04.2021 01:55 •  Информатика

Лёгкая по паскалю! составьте программу, которая позволяет заменить в строке s слово t1 на слово t2. строку s и слова t1 и t2 введите с клавиатуры. пример ввода: на небе появилась туча. туча луна пример вывода: на небе появилась луна.

Показать ответ
Ответ:
svetlanasevasty
svetlanasevasty
04.10.2020 15:34
Var
  s, t1, t2, st: string;
  i: integer;
begin
  readln(s);
  readln(t1);
  readln(t2);
  if pos(t1, s) <> 0 then
    i := pos(t1, s);
  st := copy(s, 1, i - 1);
  st := st + t2;
  st := st + copy(s, i + length(t1), length(s));
  writeln(st);
  readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота