В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
alenamalaya20
alenamalaya20
27.01.2023 03:52 •  Информатика

Лёгкая по паскалю! , ! составьте программу которая позволяет удалить второе слово строки s. строку s, состоящую из 2 слов, разделённых пробеламі, введите с клавbатуры.

Показать ответ
Ответ:
VladSolo
VladSolo
04.10.2020 17:57
Var s: string; x,i: byte;
begin
writeln('Введите строку:');
readln(s);
for i:=2 to length(s) do begin
  if s[i]=' '
    then begin
      x:=i+1;
      while (s[x]<>' ') and (x<length(s)) do begin
        delete(s,x,1);
      end;
      delete(s,x,1);
      break;
    end;
end;
writeln(s);
end.

Пример 1:
мама мыла
мама 
Пример 2:
Мама мыла раму
Мама раму

PS: считается, что строка не начинается с пробела и не может быть два пробела подряд
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота