В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
пингвин38
пингвин38
27.11.2021 13:31 •  Информатика

КУМИР Начертите фигуру, изображен- ную на рисунке, используя вс
гательный алгоритм с аргументами
Для рисования отдельного элемен-
та. Количество повторений эле-
ментов и количество повторений
прямоугольников внутри одного
элемента задается пользователем,​


КУМИР Начертите фигуру, изображен- ную на рисунке, используя вс гательный алгоритм с аргументамиДля

Показать ответ
Ответ:
vikafirsova
vikafirsova
25.04.2023 21:09
Держи. Программа написана для PascaABC.net.
Что бы изменить количество массива - измени значение в графе const в самом верху программы. Первый отрезок программы (до пустой строчки) - заполнение и вывод массива из случайный значений из промежутка [a,b].
Вторая часть программы(в серединке) нахождение таких элементов массива, которые удовлетворяют условиям задачи - т.к. локальный минимум - в занос индексов этих элементов в новый массив d.
Последняя строчка - вывод ответ, если массив с индексами пустой - напишет "не найдено" , а если такие элементы есть, то выведет все индексы на экран.
Напишите программу, которая заполняет массив случайными числами в диапазоне [a, b], выводит его на э
0,0(0 оценок)
Ответ:
satvika61
satvika61
31.05.2022 22:11
Program vtor_bukva;

var
  S: String;

begin
  Writeln('введите исходное предложение: ');
  Readln(s);
  delete(s, pos(' ', s), 1);
  write('Последняя буква второго слова=');
  if pos(' ', s) <> 0 then write(s[pos(' ', s) - 1])
  else write(s[length(s)]);
  readln(s);
end.

Твоя программа выводит символ, стоящий перед ПЕРВЫМ пробелом. А нужно, чтобы выводила символ, стоящий перед вторым пробелом. Не стоит забывать, что второго пробела может и не быть. Так что, я удаляю первый пробел. А потом делаю проверку: есть ли ещё пробелы (if pos(' ', s) <> 0)? Если пробелы есть, то программа выводит букву, следующую перед вторым пробелом (или последнюю букву второго слова). Если пробелов нет (всего два слова в предложении было введено), то программа выводит последнюю букву (s[length(s)]). Если что-то не понятно, в лс.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота