В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
1123454321макс
1123454321макс
23.11.2022 10:20 •  Информатика

Кто -святой. составить программу, которая заполняет 11 элементов одномерного массива случайным образом, вычисляет их сумму, определяет min элемент в массиве

Показать ответ
Ответ:
владислав186
владислав186
03.10.2020 01:27
Var x : array[1..11] of integer;
   n,s,i,min : integer;
begin
Randomize;
n:=11;
writeln('Сгенерированный массив:');
for i:=1 to n do
 begin
  x[i]:=random(21)-10;
  write(x[i],' ');
end;
writeln;
 s:=0;
min:=x[1];
for i:=1 to n do
 begin
 if x[i]<min then min:=x[i];
 s:=s+x[i]
 end;
writeln('s = ',s:5,'   min=',min);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота