КТО РАЗБИРАЕТСЯ В PYTHON РЕШИТЕ PLEASE ЭТУ ЗАДАЧУ Электронный попугай
Боба очень любит попугаев, но у него аллергия на птиц. Поэтому он захотел создать себе электронного попугая.
Напишите функцию parrot(phrase), которая будет симулировать речь попугая. Если в переменной phrase находится предложение, которое попугай слышал хотя бы один раз, то функция печатает эту фразу.
1) D:\ Литература \ 20 Век \Том 1. Поднялись на 1 уровень вверх = D:\ Литература\ 20 век Создали подкатолог Шолохов = D:\ Литература \ 20 век \ Шолохов Перемесили файл том1 в подкаталог Шолохов = D:\ Литература \ 20 век \ Шолохов\ Том1.
2) Начали в каталоге \Отчет поднялись на один уровень вверх = \..\ Отчет Спустились на 2 уровня вниз и оказались в C:\Школа\Дежурство\График значит с последних каталогов поднимемся на 2 уровня вверх и получаем C:\Школа Значит изначально путь был C:\Школа\Отчет
3) По аналогии с задачей под №1 : D:\Фото\2012\Общая D:\Фото\2012 D:\Фото\2012\9 Класс D:\Фото\2012\9 Класс\Общая
Коробки (Время: 1 сек. Память: 16 Мб Сложность: 19%)
На столе лежат коробка размера A1 × B1 × C1 и коробка размера A2 × B2 × C2. Выясните можно ли одну из этих коробок положить в другую, если разрешены повороты коробок вокруг любого ребра на угол 90 градусов. Входные данные
Первая строка входного файла содержит три целых числа A1, B1 и C1. Вторая строка входного файла содержит три целых числа A2, B2 и C2. Все числа положительны и не превосходят 1000. Выходные данные
Если коробки одинаковы, выведите "Boxes are equal". Если первая коробка может быть положена во вторую, выведите "The first box is smaller than the second one". Если вторая коробка может быть положена в первую, выведите "The first box is larger than the second one". Иначе, выведите "Boxes are incomparable" program gt; label 1; var a,b:array[1..1000]of longint; a1,b1,c1,a2,b2,c2,p,l,n,i,j:longint; begin read(a1,b1,c1,a2,b2,c2); a[1]:=a1;a[2]:=b1;a[3]:=c1; b[1]:=a2;b[2]:=b2;b[3]:=c2; for i:=1 to 2 do begin for j:=1 to 3-i do begin p:=A[j];l:=A[j+1]; if A[j]>A[j+1] then begin A[j]:=l; A[j+1]:=p; end; end; end; for i:=1 to 2 do begin for j:=1 to 3-i do begin p:=b[j];l:=b[j+1]; if b[j]>b[j+1] then begin b[j]:=l; b[j+1]:=p; end; end; end; if(a[1]=b[1])and(a[2]=b[2])and(a[3]=b[3])then begin writeln('Boxes are equal'); goto 1; end; if((a[1]<=b[1])and(a[2]<b[2])and(a[3]<=b[3]))or ((a[1]<b[1])and(a[2]<=b[2])and(a[3]<=b[3]))or ((a[1]<=b[1])and(a[2]<=b[2])and(a[3]<b[3]))then begin writeln('The first box is smaller than the second one'); goto 1; end; if((a[1]>=b[1])and(a[2]>b[2])and(a[3]>=b[3]))or ((a[1]>=b[1])and(a[2]>=b[2])and(a[3]>b[3]))or ((a[1]>b[1])and(a[2]>=b[2])and(a[3]>=b[3]))then begin writeln('The first box is larger than the second one'); goto 1; end; writeln('Boxes are incomparable'); 1: end.
Поднялись на 1 уровень вверх = D:\ Литература\ 20 век
Создали подкатолог Шолохов = D:\ Литература \ 20 век \ Шолохов
Перемесили файл том1 в подкаталог Шолохов =
D:\ Литература \ 20 век \ Шолохов\ Том1.
2) Начали в каталоге \Отчет
поднялись на один уровень вверх = \..\ Отчет
Спустились на 2 уровня вниз и оказались в C:\Школа\Дежурство\График
значит с последних каталогов поднимемся на 2 уровня вверх и получаем C:\Школа
Значит изначально путь был C:\Школа\Отчет
3) По аналогии с задачей под №1 :
D:\Фото\2012\Общая
D:\Фото\2012
D:\Фото\2012\9 Класс
D:\Фото\2012\9 Класс\Общая
(Время: 1 сек. Память: 16 Мб Сложность: 19%)
На столе лежат коробка размера A1 × B1 × C1 и коробка размера A2 × B2 × C2. Выясните можно ли одну из этих коробок положить в другую, если разрешены повороты коробок вокруг любого ребра на угол 90 градусов.
Входные данные
Первая строка входного файла содержит три целых числа A1, B1 и C1. Вторая строка входного файла содержит три целых числа A2, B2 и C2. Все числа положительны и не превосходят 1000.
Выходные данные
Если коробки одинаковы, выведите "Boxes are equal". Если первая коробка может быть положена во вторую, выведите "The first box is smaller than the second one". Если вторая коробка может быть положена в первую, выведите "The first box is larger than the second one". Иначе, выведите "Boxes are incomparable"
program gt;
label 1;
var a,b:array[1..1000]of longint;
a1,b1,c1,a2,b2,c2,p,l,n,i,j:longint;
begin
read(a1,b1,c1,a2,b2,c2);
a[1]:=a1;a[2]:=b1;a[3]:=c1;
b[1]:=a2;b[2]:=b2;b[3]:=c2;
for i:=1 to 2 do
begin
for j:=1 to 3-i do
begin
p:=A[j];l:=A[j+1];
if A[j]>A[j+1] then begin
A[j]:=l;
A[j+1]:=p;
end;
end;
end;
for i:=1 to 2 do
begin
for j:=1 to 3-i do
begin
p:=b[j];l:=b[j+1];
if b[j]>b[j+1] then begin
b[j]:=l;
b[j+1]:=p;
end;
end;
end;
if(a[1]=b[1])and(a[2]=b[2])and(a[3]=b[3])then begin
writeln('Boxes are equal');
goto 1;
end;
if((a[1]<=b[1])and(a[2]<b[2])and(a[3]<=b[3]))or
((a[1]<b[1])and(a[2]<=b[2])and(a[3]<=b[3]))or
((a[1]<=b[1])and(a[2]<=b[2])and(a[3]<b[3]))then begin
writeln('The first box is smaller than the second one');
goto 1;
end;
if((a[1]>=b[1])and(a[2]>b[2])and(a[3]>=b[3]))or
((a[1]>=b[1])and(a[2]>=b[2])and(a[3]>b[3]))or
((a[1]>b[1])and(a[2]>=b[2])and(a[3]>=b[3]))then begin
writeln('The first box is larger than the second one');
goto 1;
end;
writeln('Boxes are incomparable');
1:
end.