В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nastyamal0101
nastyamal0101
19.02.2022 19:20 •  Информатика

Контрольная работа по теме «Начала программирования». Вариант I

В заданиях группы А выбрать правильный ответ.

А1. Что из нижеперечисленного не входит в алфавит языка Паскаль?

латинские строчные и прописные буквы,

арабские цифры,

русские строчные и прописные буквы,

знак подчёркивания.

А2. Какая последовательность символов может служить именем программы в языке Паскаль?

_test, 2) nos_56, 3) 56_ttt, 4)Игорь78.

А3. Обозначение целочисленного типа данных в языке Паскаль.

integer, 2) real, 3) char, 4) string.

А4. В результате выполнения фрагмента программы:

a:=3,14;

writeln (frac(a));

на печать будет выведено:

14, 2) 3.14, 3) 3, 4) 3,14.

А5. В каком из условных операторов допущена ошибка?

if b=0 then writeln ( ‘Деление не возможно‘);

if a

if a>b then max:=a else max:=b;

if (a>b) and (b>0) then c:=a+b.

А6. В результате выполнения фрагмента программы

a:=5;

b:=20;

a:=a-b/2;

if a>b then c:=a+b else c:=b-a;

переменная с примет значение:

25, 2) 14,5, 3) -15, 4) -14,5.

А7. Цикл во фрагменте программы :

a:=0.5;

s:=0;

i:=0;

repeat i:=i+1; b:=1/i; s:=s+a; until b

выполнится

0 раз, 2) 2 раза, 3) 1 раз, 4) 4 раза.

А8. С оператора while в языке Паскаль программируется:

цикл - ПОКА, 2) цикл с параметром, 3) цикл – ДО, 4) все вышеперечисленные.

В заданиях группы Б представить полное решение или записать ответ.

Б1. Определите значение переменной b после выполнения фрагмента программы:

a:=4;

b:=3;

a:=12/a*b;

b:=a+b*2.

В ответе укажите одно целое число – значение переменной b.

практическая работа
написать программу вывода всех чисел [1056..50689], которые делятся нацело на 3 и на 6, но не делится на 8,9 и 5

Показать ответ
Ответ:
artslk
artslk
15.03.2020 20:52

4:

#include<iostream>

#include<algorithm>

#include<string>

using namespace std;

int main()

{

   string num{};

   cin>>num;

   if(int counter=count(begin(num),end(num),'9') ; counter<=1)

   {

       cout<<"Yes"<<endl;

   }

   else

   {

       cout<<"No"<<endl;

   }

   return 0;

}

5:

#include<iostream>

#include<algorithm>

#include<string>

using namespace std;

int main()

{

   string num{};

   cin>>num;

   if(bool test=all_of(begin(num),end(num),[](char a){return atoi(&a)%2==0;}) ; test==1)

   {

       cout<<"Yes"<<endl;

   }

   else

   {

       cout<<"No"<<endl;

   }

   return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
VolhaRednaya8
VolhaRednaya8
10.08.2022 16:37

Объе́кт — философская категория, обозначающая вещь, явление или процесс, на которые направлена предметно-практическая, управляющая и познавательная деятельность субъекта;

Моде́ль (фр. modèle от лат. modulus «мера, аналог, образец») — система, исследование которой служит средством для получения информации о другой системе; представление некоторого реального процесса, устройства или концепции.

Трёхмерная графика — раздел компьютерной графики, посвящённый методам создания изображений или видео путём моделирования объёмных объектов в трёхмерном пространстве. 3D-моделирование — процесс создания трёхмерной модели объекта. Задача 3D-моделирования — разработать зрительный объёмный образ желаемого объекта.

Программы для цифрового скульптинга (Pixologic ZBrush, Autodesk Mudbox).

Игровые движки (Unreal Engine 4, Unity 5, CryEngine 3).

Узкоспециализированные приложения, «заточенные» под конкретные задачи (анимация жидкостей – RealFlow, создание текстур – Mari и пр.).

Универсальные 3D редакторы (Cinema 4D, 3Ds Max, Maya, Houidini и т.д.).

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота