В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
shakirqasanov
shakirqasanov
21.04.2023 19:14 •  Информатика

Конец семестра, я в завале : ( 1) написать программу, которая по вводимому числу от 1 до 11 (номеру класса) выдаёт соответствующее . например, если k=1 - «, первоклассник» , если k=9 - «, девятиклассник». учесть возможную ошибку при вводе числа с клавиатуры. 2) оператора case составить программу определения стоимости разговора по телефону с учётом скидки 20%, предоставляемой по субботам и воскресеньям. минута разговора стоит 2,3 руб.вывести: день недели звонка, сумму без скидки и сумму со скидкой. если скидка не предоставляется - написать об этом. учесть возможную ошибку при вводе числа с клавиатуры. пояснение: с клавиатуры пользователь вводит длительность разговора и номер дня недели от 1 до 7.)

Показать ответ
Ответ:
malina20023
malina20023
15.06.2020 04:14
');
    else writeln('вы должны ввести число от 1 до 11')
  end;
  writeln('');
end.

 

 

 

program Phone;
var day:integer; time:real; week:array[1..7] of string;
begin
  week[7]:='Воскресенье';
  week[6]:='Суббота';
  week[5]:='Пятница';
  week[4]:='Четверг';
  week[3]:='Среда';
  week[2]:='Вторник';
  week[1]:='Понедельник';
  write('введите длительность разговора в минутах ');
  readln(time);
  write('введите номер дня недели ');
  readln(day);
  writeln(' alphaeus is thinking...  ');
  case day of
    '1'..'5':
       begin
         writeln(week[day]);
         writeln('Сумма без скидки - ', 2.3*time);
         writeln('Сумма скидкой - ', 0.8*2.3*time);
         writeln('Скидка не предоставляется');
       end;
    '6','7':
       begin
         writeln(week[day]);
         writeln('Сумма без скидки - ', 2.3*time);
         writeln('Сумма скидкой - ', 0.8*2.3*time);
         writeln('Вам предоставлена скидка!');
       end;
    else writeln('вы ввели неправильный номер дня недели')
  end;
  writeln'');
end.

0,0(0 оценок)
Ответ:
angelinasolovev
angelinasolovev
15.06.2020 04:14

А можно поподробнее что подразумевается под учесть ошибку, имеется ввиду если число не соответсвует от 1 до 11 вывести "ошибка при вводе"?

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота