Компьютеры и программы Запишите возможные команды исполнителя Рисователь:
Отметьте в этом списке операционные системы:
Используя словари, выпишите значения иностранных слов:
hardware (англ.)
software (англ.)
desktop (англ.)
informatique (фр.)
user (англ.)
programmer (англ.)
Определите, какие действия (получение, хранение, обработка или передача) выполняются с информацией:
Мама оставила записку Пете.
Кошка нюхает еду.
Сеня решает задачу.
Книги стоят на полке.
Маша послала СМС.
Платон читает книгу.
Кирилл бросил записку на первую парту.
Археологи ведут раскопки.
Определите типы входных данных и результатов для задач обработки данных. Если входных данных несколько, укажите тип каждой величины:
Определить количество букв А в слове:
Входные данные: слово (строка)
Результат: количество букв А в слове (число)
Определить длину предложения:
Входные данные:
Результат:
Переставить символы слова в обратном порядке:
Входные данные:
Результат:
Найти номер символа, с которого начинается заданное слово в предложении.
Входные данные:
Результат:
Вычислить квадрат числа.
Входные данные:
Результат:
Записать число словами.
Входные данные:
Результат:
Определить количество гласных в слове.
Входные данные:
Результат:
Какие параметры (входные данные) могут быть у команд стиральной машины:
«залить воду»
1)
2)
«отжать»
1)
2)
Какие параметры могут быть у команд Рисователя:
«линия»
1)
2)
«прямоугольник»
1)
2)
3)
Определите тип каждого устройства:
Память Ввод Вывод
клавиатура
мышь
монитор
лазерный диск
принтер
микрофон
сенсорный экран
веб-камера
флэш-карта
Решите кроссворд:
По горизонтали:
Часть компьютера, которая выполняет вычисления.
Мощный компьютер для решения задач особой сложности.
Человек, который использует компьютер.
Человек, который пишет программы для компьютеров.
Компьютер + сотовый телефон.
Наука об автоматической обработке информации.
Универсальное устройство для хранения, обработки и передачи данных.
Устройство для хранения информации.
Информация, «очищенная» от эмоций и чувств.
Какое слово получилось в закрашенных клетках?
Дайте определение этому слову:
Определите типы связей в каждом случае:
Разновидности Части целого Ни то, ни другое
фрукт (яблоко, груша, абрикос)
автомобиль (кузов, двигатель, руль)
рыба (щука, плотва, ленок, омуль)
мама (папа, сын, дочь)
столовый прибор (вилка, ложка, нож)
растение (корни, листья, стебли)
завод (директор, бухгалтер, рабочий)
Узнайте, используя дополнительные источники, что означает слово «интеллект»:
using namespace std;
int main() {
int m;
cout << "m = ", cin >> m, cout << "\n";
int b[m];
srand(time(NULL));
cout<<"array:\n";
for (int i=0; i<m; i++)
{
b[i]=rand() % 50;
cout<<b[i]<<" ";
}
cout << "\n";
for (int i=0; i<m; i++)
if ((i+1)%2==0) b[i] *= 2;
else b[i]=0;
for (int i=0; i<m; i++) cout << b[i] << " ";
cout << "\n";
return 0;
}
Пример:
m = 10
array:
47 3 29 46 36 31 2 2 20 20
0 6 0 92 0 62 0 4 0 40
abs(−16) = 16
sqr(b) = 256
sqr(b + b) = 1024
Объяснение:
program x1; // Название программы
var // Раздел для описания переменных
a, b, c: integer; // Объявление целочисленных переменных:
a - хранение первого введенного с клавиатуры числа;
b - хранение второго введенного с клавиатуры числа;
с - хранение максимального из них.
begin // Начало программы
a := -16; // Присваиваем значение "-16" в переменную а
b := abs(a); // Присваиваем модуль числа а в переменную b
writeln('abs(−16)=', b); // Выводим в консоль
c := sqr(b); // Присваиваем квадрат числа b в переменную c
writeln('sqr(b)=', c); // Выводим в консоль
c := sqr(b + b); // Присваиваем квадрат числа b + b в переменную c
writeln('sqr(b+b)=', c); // Выводим в консоль
end. // Конец программы