В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Как программируется цикл с предусловием на паскале? почему алгоритм вычисления n! должен быть циклическим ? что такое формализация ?

Показать ответ
Ответ:
ано6
ано6
02.07.2020 23:09
1. while <условие> do
        begin
              <действие>
              <действие>
             .......
        end;
2. Не обязательно, например, можно это сделать рекурсивно:
     1. \ var \ n:integer; \\ &#10;2. \ function \ fact(j:integer):integer; \\ &#10;3. \ \ \ \ begin \\ &#10;4. \ \ \ \ \ \ \ if \ (j=1) \ or \ (j=0) \ then \ fact:=1 \\ &#10;5. \ \ \ \ \ \ \ else \ fact:=j*fact(j-1); \\ &#10;6. \ \ \ \ end; \\ &#10;7. \ begin \\ &#10;8. \ \ cls; \\ &#10;9. \ \ write('Vvedite \ n='); \\ &#10;10. \ \ readln(n); \\ &#10;11. \ \ writeln('n!=',fact(n)); \\ &#10;12. \ end.
3. создание математической модели данной задачи, (гyгл в
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота