В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
zaira0
zaira0
30.03.2022 12:54 •  Информатика

Как можно применять условия в жизни? ЗАПИШИТЕ ПРОГРАММУ СООТВЕСТВУЮЩУЮ ЗАДАНИЮ,А НЕ ПРГРАМЫ КОТОРЫЕ Я БУДУ ИЗУЧАТЬ ЧЕРЕЗ НЕСКОЛЬКО ЛЕТ Путешествуя на автомобиле, вы заехали на заправку. До следующей заправки 200 километров.

Напишите программу, которая будет определять, нужно ли вам заправляться или же можно подождать до следующей станции.

Программа должна спрашивать:

Каков размер вашего бензобака в литрах?

Сколько горючего в бензобаке (в процентах)?

Сколько километров проходит автомобиль на одном литре бензина?

Пример входа №1:
Каков размер вашего бензобака в литрах? 60
Сколько горючего в бензобаке (в процентах)? 30
Сколько километров проходит автомобиль на одном литре бензина? 8

Пример результата №1:
Вы можете проехать еще 144.0 км.
До следующей заправки 200 км
ЗАПРАВЬТЕСЬ СЕЙЧАС!

Пример входа №2:
Каков размер вашего бензобака в литрах? 60
Сколько горючего в бензобаке (в процентах)? 40
Сколько километров проходит автомобиль на одном литре бензина? 10

Пример результата №2:
Размер бензобака: 60.0
Заполненность в процентах: 40.0
Км на литр: 10.0
Вы можете проехать еще 240.0 км
До следующей заправки 200 км
Можно подождать следующей заправки

Показать ответ
Ответ:
Лисёнка2005
Лисёнка2005
18.05.2021 05:26

var

   i: Integer;

   l: Single;

   counter: Integer;

begin

 counter := 0;

 for i := 0 to 14 do begin

   Read(l);

   if l >= 165 then

       counter := counter + 1 ;

 end;

 Writeln(counter);

end.

Второй вариант

const

 cN: Integer = 15;

 cMinSuitableLength: Single = 165;

var

 arr: array [0..14] of Single;

 i, counter: Integer;

begin

 for i := 0 to Length(arr) - 1 do

   Read(arr[i]);

 counter := 0;

 for i := 0 to Length(arr) - 1 do

   if arr[i] >= cMinSuitableLength then

     counter := counter + 1;

 Writeln(counter);

end.

Объяснение:

0,0(0 оценок)
Ответ:
806nikita
806nikita
22.08.2021 03:15

Объяснение:

І.

Комп'ютерний вірус починає діяти після завантаження зараженого файлу. Тільки після цього вірус починає діяти самостійно.

"Дії" на комп'ютер вірусів бувають абсолютно різні: від самовільного відкриття сайтів (здебільшого рекламного характеру) в браузері, уповільнення роботи комп'ютера та зменшення обсягу оперативної пам'яті до зникнення файлів (або їх зміни), форматування жорсткого диска та неспроможністю завантажити комп'ютер.

ІІ.

"Лікування" файлів антивірусом полягає в вилученні з зараженої програми коду (тіла) віруса.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота