Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
DANILADEMON
25.05.2020 09:22 •
Информатика
КАК МОЖНО БЫСТРЕЕ.ПЛАЧУ НЕ ВАЖНО КАКОЙ ЯЗЫК ПРОГРАММИРОВАНИЯ. ГЛАВНОЕ КАК МОЖНО БЫСТРЕЕ
Задание на фото.Если успеете за 30 минут.Накину еще
Показать ответ
Ответ:
Ram543
13.12.2020 06:29
While (tnum != 0) //tnum, tden - числитель и знаменатель искомой дроби
{
if (tnum < tden)
{
temp = tnum;
tnum = tden;
tden = temp;
}
tnum = tnum - tden;
}
gcd = tden; //вычисляем наибольший общий делитель
numerator = numerator / gcd; //делим числитель и знаменатель на
НОД, получаем сокращенную дробь
denominator = denominator / gcd;
0,0
(0 оценок)
Ответ:
evgenijpetrov
08.03.2023 07:22
Vara,b,c,d,x1,x2: real;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
eliseevivan
18.01.2020 17:32
Напишите программу, вычисляющую значение функции у, если х 0, то у=10, если х 0, то у=-10...
LeviAcker
30.10.2022 07:26
1.что такое файл? 2.из каких частей состоит имя файла? 3.кто или что дает имя файлу? 4.кто или что присваивает файлу расширение? 5.сколько символов может включать имя файла?...
ilyailushin
30.10.2022 07:26
1.что такое файл? 2.из каких частей состоит имя файла? 3.кто или что дает имя файлу? 4.кто или что присваивает файлу расширение? 5.сколько символов может включать имя файла?...
mashanemiro110p08m38
19.02.2023 22:50
1. Знайдіть помилку в наступних фрагментах програм: beginy: =0; for x: =0.1 to 9 do y: = y+ sqr(x); end;2. begin m:=4; for y:=9 to 1 do begin f:=m+2+y; writeln( f= ,f); end;...
m20m
02.04.2023 23:33
Сызықтық алгоритмдерді программалау Квадрат түбірді табу үшін қандай функция қолданылатынын көрсет. pow(х, у) degrees(у) radians(х) sqrt(у)...
dashapocta
18.08.2022 18:35
Построить логические схемы функций F=A+неВ F=A*B*C F=не(A+B)*(A*B)...
МаминаГадость12
15.02.2023 20:15
Какую последнюю цифру имеет произведение всех нечётных чисел от 1 до 999. 20 варианты ответа 1)0 2)1 3)5 4)9...
andreyshilenko
15.02.2023 20:15
Решите пример : (4 3/4-3,75)+(9 5/6-3 17/18)...
pedyxa12
15.02.2023 20:15
Решите уравнение : 5 8/21-х=2 9/14...
lizasolnce2004
15.02.2023 20:15
Выразите длину дороги 3,7 км в м, см, мм...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
{
if (tnum < tden)
{
temp = tnum;
tnum = tden;
tden = temp;
}
tnum = tnum - tden;
}
gcd = tden; //вычисляем наибольший общий делитель
numerator = numerator / gcd; //делим числитель и знаменатель на
НОД, получаем сокращенную дробь
denominator = denominator / gcd;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.