В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
yaya4
yaya4
10.01.2022 13:14 •  Информатика

Как много смыслов в простом пожелании! Напишите программу, которая найдет все строки, в которых есть что-то доброе (достаточно проверить наличие подстроки добр), а потом выберет из них строку с наименьшей длиной. Формат ввода

Вводятся строки, пока не будет введена строка с фамилией Бэггинс.

Формат вывода

Вывести наименьшую длину строки, в которой есть что-то доброе. Если таких не оказалось, вывести 0.Торопиться некуда таким добрым утром, целый день впереди!

От них одно беспокойство и неприятности!

Еще,

Показать ответ
Ответ:
turkmenochka75
turkmenochka75
31.08.2020 22:20
Что мы знаем о войне немного  по рассказам бабушек и мам  знаем, что надежда и тревога  об руку ходили по домам  слухи зависали  как знамена  дымом застилался горизонт  многоверстный и многоименный  жаждал крови ненасытный фронт  а из тыла за волной волна  шла латать верховные промашкивсасывала мальчиков война   и выплевывала мертвые бумажкикаждый шаг   к победе ли к бедесводки измеряли расстояньем  даже самый распобедный день  был комуто вечным расставаньемгоды возвращающий экраночевидцев честные романывсе равно останутся обманомссадины не заменяют рантолько изредка за толщей дней  вдруг всплеснёт сирены голос лютыйзамирая криками детей  и застынет сердце на минуту
0,0(0 оценок)
Ответ:
NeZnaiYProsto
NeZnaiYProsto
04.06.2023 05:44

#include <iostream>

using namespace ::std;

int main()

{

   setlocale(LC_CTYPE , "rus");

   

   int n, i, j = 0, k = 0;

   double s = 0;

   cout << "Введите количество элементов: \n";

   cin >> n;

   float x;

   float *massiv = new float[n];

   if (!massiv)

   {

       cout << "Сбой программы!\n";

       system("pause");

        return 0;

   }

   cout << "Введите массив с " << ' ' << n << ' ' << "элементов\n";

   for (i = 0; i < n; i++)

       cin >> *(massiv + i);

   cout << "Заданный массив: " << endl;

   for (int i = 0; i < n; i++)

       

       cout << *(massiv + i) << ' ' << endl;

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i]>0)

           k++;

   }

   cout << " Количество положительных элементов = " << k << '\n';

 

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i] == 0) {

           j = massiv[i];

           x = i;

       }

   }

 

   for (i = x; i<n; i++)

       s += massiv[i];

 

   cout << "Сумма =" << s;

   float *massiv2 = new float[n];

   if (!massiv2)

   {

       cout << "Сбой программы !\n";

       system("pause");

       return 0;

   }

   for (i = 0; i < n; i++)

       if (massiv[i] <= 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

 

   for (i = 0; i < n; i++)

       if (fabs(massiv[i]) > 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

   cout << endl << "Отсортированный массив: " << endl;

   for (int j = 0; j < n; j++)

       cout << '\n' << massiv2[j] << ' ';

 

   delete[] massiv;

   delete[] massiv2;

   system("pause");

   return 0;

}

В работо не сомневайся.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота