Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
kuzmichkinvale
31.03.2022 05:23 •
Информатика
Известны координаты вершин авс треугольника. напишите программу вычисляющую s-площадь этого треугольника. xa=2 ya=1 xb=6 yb=5 xc=10 yc=1
Показать ответ
Ответ:
krnshlpn
23.09.2020 12:24
// тестировалось на C#.Net Framework 4.5
using System;
class Program
{
static void Main()
{
int x1 = 2, y1 = 1;
int x2 = 6, y2 = 5;
int x3 = 10, y3 = 1;
var a = Distance(x2, y2, x3, y3);
var b = Distance(x1, y1, x3, y3);
var c = Distance(x2, y2, x1, y1);
Console.WriteLine("S = {0}", Square(a, b, c));
Console.ReadKey();
}
//растояние между точками
static double Distance(int x1, int y1, int x2, int y2)
{
return Math.Sqrt((x2 - x1) * (x2 - x1) + (y2 - y1) * (y2 - y1));
}
//формула герона
static double Square(double a, double b, double c)
{
var p = (a + b + c) / 2;
return Math.Sqrt(p * (p - a) * (p - b) * (p - c));
}
// теорема косинусов
static double Angle(double a, double b, double c)
{
return Math.Acos((b * b + c * c - a * a) / (2 * b * c));
}
static bool IsAcuteAngel(double alpha)
{
return alpha < Math.PI / 2;
}
}
0,0
(0 оценок)
Популярные вопросы: Информатика
plimita134
01.09.2021 20:19
, ОТ Подготовьте презентацию минимум из 5 слайдов на тему Я ученик Домашней школы . Предусмотрите наличие титульного слайда, слайда с содержанием, слайда со списком используемой...
зайчик851
03.07.2020 11:31
Можно полное решение? Желательно с объяснением. Сколько значащих нулей в двоичной записи числа 4^1024 + 8^1025 - 2^1026 - 140?...
Arino4ka7381
31.12.2021 11:32
Впаскале. с оператора while напишите программу определения идеального веса для взрослых по формуле: ид. вес=рост-100. выход из цикла : значение роста=250...
69devil69
24.09.2022 05:01
Что из перечисленного не является физической моделью объекта Глобус Дорожный знак Детская игрушечная железная дорога Все перечисленное является физическими моделями объектов...
ladybird1
28.05.2023 07:32
Расскажите как решаются такие примеры, как этот - 8,9 - 7,8...
vladisden
28.05.2023 07:32
20 найдите производную функцию у=e^x+3sin х...
гпү
28.05.2023 07:32
Из гондолы воздушного шара, движущегося горизонтально со скоростью 10 м/с на высоте 450 м, выпало тело. под каким углом упадет тело на землю, если пренебречь сопротивлением...
EvgeshaKhomenco2005
28.05.2023 07:32
Во сколько раз изменится внутренняя энергия газа при увеличении его температуры от 27°до237° ?...
ваня10001
28.05.2023 07:32
Найдите синонимы следующих слов и словосочетаний: 1. to sleep; 2. to have serious problems; 3. garbage; 4. to forecast; 5. to understand; 6. speed; 7. people; 8. condition;...
niknem111
28.05.2023 07:32
Через вершину b треугольника проведена прямая ,пересекающая сторону ac в точке d так что угол bdc равен углу abc .найдите длину стороны bc и отношение bd: ba если ad...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using System;
class Program
{
static void Main()
{
int x1 = 2, y1 = 1;
int x2 = 6, y2 = 5;
int x3 = 10, y3 = 1;
var a = Distance(x2, y2, x3, y3);
var b = Distance(x1, y1, x3, y3);
var c = Distance(x2, y2, x1, y1);
Console.WriteLine("S = {0}", Square(a, b, c));
Console.ReadKey();
}
//растояние между точками
static double Distance(int x1, int y1, int x2, int y2)
{
return Math.Sqrt((x2 - x1) * (x2 - x1) + (y2 - y1) * (y2 - y1));
}
//формула герона
static double Square(double a, double b, double c)
{
var p = (a + b + c) / 2;
return Math.Sqrt(p * (p - a) * (p - b) * (p - c));
}
// теорема косинусов
static double Angle(double a, double b, double c)
{
return Math.Acos((b * b + c * c - a * a) / (2 * b * c));
}
static bool IsAcuteAngel(double alpha)
{
return alpha < Math.PI / 2;
}
}