В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kwasmarianna
kwasmarianna
10.05.2020 19:12 •  Информатика

Известны длины сторон треугольника a, b, c. Написать программу, вычисляющую площадь этого треугольника (по формуле Герона). Выполнить программу для исходных данных a=3, b=4, c=5. Язык Паскаль я не понимаю как это делается

Показать ответ
Ответ:
Fatimochkaananas
Fatimochkaananas
06.08.2020 13:50

program GWR;

var

 p1,a,b,c,s:real;

 begin

 writeln('Введите чему равны стороны треугольников :');

 readln(a,b,c);

 p1 := (a + b + c)/ 2;

 s := sqrt(p1*(p1-a)*(p1-b)*(p1-c));

 write(s);

 end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота